pdf as attachement: "open with" is grayed on certain messages

RESOLVED DUPLICATE of bug 66677

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 66677
13 years ago
10 years ago

People

(Reporter: Dmitry Karasik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8.0.1) Gecko/20060215 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8.0.1) Gecko/20060215 Firefox/1.5.0.1

test case: the mailbox can be downloaded from http://www.karasik.eu.org/misc/faulty-pdfs.mbox.gz
( warning - unzipped file is 5M )

The mailbox above contains one of the messages I'm seeing, which contains a mixed bag of pdf and doc files, and where pdf files cannot be opened with an external applications. Normally, unless "do this automatically" checkbox is not set, an attachment, if clicked, causes a dialog with 2 choices, "open with" and "save as" to appear. If you try to click on PDF files in the attachments, the "open with" checkbox is grayed. I suspected this was because of the deep attachment scheme, but DOC files don't have such problem. OTOH, I tried to attach the PDF files one by one, and Thunderbird works fine with these (also mangled files), so it doesn't seem like the PDF files are in any way faulty.

The PDF and DOC files are deliberately mangled, so opening these successfully is not the point; the point is that the "open with" checkbox is sometimes disabled for reasons unknown.

Thunderbird version 1.5 build 20060215.


Reproducible: Always

Steps to Reproduce:
1. download and gunzip http://www.karasik.eu.org/misc/faulty-pdfs.mbox.gz, put the faulty-pdfs.mbox in your "Local Folders" 
2. click on the message, try to "open with" any of the attached PDF files

Actual Results:  
thunderbird displays "opening xxx.pdf" file dialog, where "open with" checkbox is disabled

Expected Results:  
thunderbird displays "opening xxx.pdf" file dialog, where "open with" checkbox is enabled

Comment 1

12 years ago
*** Bug 351455 has been marked as a duplicate of this bug. ***

Comment 2

12 years ago
Dmitry, after looking at your faulty-pdfs.mbox example, I suspect that the problem is that the PDF attachment are all designated as "Content-Type: application/octet-stream". If they would by marked "application/pdf" instead, the problem might go away (although I haven't tried).
(Reporter)

Comment 3

12 years ago
That might work as a short-term solution, but I think the next suggestion logically follows: why bother disabling the "open with" button at all? I don't see any scenario where this behaviour would be not counter-intuitive.

Updated

10 years ago
Assignee: mscott → nobody
Reporter, does the issue still occur in the latest supported 2.0.0.x / Shredder trunk nightlies?

(1.5.0.x is now end-of-life and the latest supported 2.0.0.x is version 2.0.0.16)
Whiteboard: closeme 2008-09-11
(Reporter)

Comment 5

10 years ago
I'm not using 2.0.0.x, and I'm afraid I won't be able to install and test the latest 2.0.0.x. I'm sorry. OTOH I've cooked up a simpler test case, a mbox with a single mail with a single PNG attachment, which is hacked to appear as application/octet-stream with wrong extension: 

http://karasik.eu.org/misc/faulty-mbox

Please test it with 2.0.0.x, it shouldn't take longer than two minutes if you have the latest version installed, and will take half of day for me.
Bug 66677 is most likely what you want here. There are about five or six other WONTFIX or open bugs on the same topic, though...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: closeme 2008-09-11
Duplicate of bug: 66677
You need to log in before you can comment on or make changes to this bug.