Closed Bug 329328 Opened 16 years ago Closed 16 years ago

CSS Manager for site-specific CSS control

Categories

(SeaMonkey :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 45848

People

(Reporter: coats, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920

I use Jesse Ruderman's bookmarklets (http://www.squarefree.com/bookmarklets/)
and I find that my *most frequently used* button is the one for his "zap style
sheets".

Would it be possible to have a "CSS Manager" that at best would allow me 
to specify "Use my style sheet for this site" (perhaps integrated with
the CSS editor), or at least to specify "Do not use this site's style
sheets" ??

Thanks!

-- Carlie J. Coats, Jr.
   carlie.coats@baronams.com
   http://www.baronams.com/staff/coats/index.html

Reproducible: Always
> Would it be possible to have a "CSS Manager" that at best would allow me 
> to specify "Use my style sheet for this site" (perhaps integrated with
> the CSS editor), 

The CSS editor is a Nvu feature and has nothing to do with changing stylesheet or using an user stylesheet. I understand your request though and I think (am not sure... bug 45848) there is a bugfile on this.
Technically, I should resolve this bug as a duplicate of bug 198169 because summary and description are the same.

> to specify "Do not use this site's style
> sheets" ??

This capability already exists in the UI: 
View/Use Style/None 
will disable author's stylesheet.
Summary: Feature-request: CSS Manager for site-specific CSS control → CSS Manager for site-specific CSS control
> I use Jesse Ruderman's bookmarklets (http://www.squarefree.com/bookmarklets/)
> and I find that my *most frequently used* button is the one for his "zap style
> sheets".

"bookmarklet creation tool to make a personal toolbar button that adds style rules to a page"
http://www.squarefree.com/userstyles/make-bookmarklet.html

Carlie, if I understood you right, you want a Stylesheet manager (to create and edit user stylesheets) and an *user* Stylesheet selector/switcher in the User Interface.
To create an user stylesheet, you can do that by editing an userContent.css file
http://www.mozilla.org/unix/customizing.html#usercss
To have an user stylesheet selector/switcher in the User Interface: this is bug 45848

Resolving as DUPLICATE of bug 45848

*** This bug has been marked as a duplicate of 45848 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Argh... I think it was better to resolve it as duplicate of bug 107023 instead.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Resolving as DUPLICATE of bug 107023

*** This bug has been marked as a duplicate of 107023 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Bug 107023 is a meta, tracker bug.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Resolving as duplicate of bug 45848 again and for good now. Sorry for the bugspam.

*** This bug has been marked as a duplicate of 45848 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Depends on: 511748
No longer depends on: 511748
You need to log in before you can comment on or make changes to this bug.