update Firefox 1.0.8 start page for ja-JP, ko-KR, zh-CN, and zh-TW

VERIFIED DUPLICATE of bug 327208

Status

()

Firefox
General
--
blocker
VERIFIED DUPLICATE of bug 327208
12 years ago
12 years ago

People

(Reporter: jay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
The default Firefox start page for Firefox 1.0.8 candidates is still going to Google (the bookmarks under "Firefox & Mozilla Links" also point to "http://start.mozilla.org/firefox", that should be updated as well).
With the latest 20060307 builds, here is what I see for all 4 locales (jaJP, koJR, zhCN, and zhTW):
about:config -> browser.startup.homepage and browser.startup.homepage_reset = resource:/browserconfig.properties
All of the locales' browserconfig.properties contains urls to the old "start.mozilla.org/firefox" page:

browser.startup.homepage=http://start.mozilla.org/firefox?client=firefox-a&rls=org.mozilla:ja-JPM:official
browser.startup.homepage_reset=http://start.mozilla.org/firefox?client=firefox-a&rls=org.mozilla:ja-JPM:official
    browser.startup.homepage=http://start.mozilla.org/firefox?client=firefox-a&rls=org.mozilla:ko-KR:official
browser.startup.homepage_reset=http://start.mozilla.org/firefox?client=firefox-a&rls=org.mozilla:ko-KR:official
    browser.startup.homepage=http://start.mozilla.org/firefox?client=firefox-a&rls=org.mozilla:zh-CN:official    browser.startup.homepage_reset=http://start.mozilla.org/firefox?client=firefox-a&rls=org.mozilla:zh-CN:official

browser.startup.homepage=http://start.mozilla.org/firefox?client=firefox-a&rls=org.mozilla:zh-TW:official    browser.startup.homepage_reset=http://start.mozilla.org/firefox?client=firefox-a&rls=org.mozilla:zh-TW:official


But according to Rafael, they should be:
    http://ja.start.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:ja:official&fr=moz2-sp
    http://ko.start.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:ko:official&fr=moz2-sp
    http://zh-CN.start.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:zh-CN:official&fr=moz2-sp
    http://zh-TW.start.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:zh-TW:official&fr=moz2y-sp
(Reporter)

Comment 1

12 years ago
Nominating for 1.0.8, I think this is a blocker we need to get in before release.
Flags: blocking-aviary1.0.8?

Comment 3

12 years ago
Shaver - is this something you can help with (since you were assiting on the MozJP issues?)

Comment 4

12 years ago
Note that the file you linked to is not localizable: you would have to add some hacky override in the locale-building process to be able to do this per-locale.

Obviously it's also not going to be "ko" but "ko-KR" and so forth, since the aviary branch only uses long locale names.
See bug 326151 comment 16 and on, which led to the filing of bug 327208. The default start pages are not localizable, they rely on build-time preprocessing to get the right URL, and server smarts to redirect to the right place. That's why I filed bug 327208. As Dave mentions in that bug, fixing it may not be trivial.

Comment 6

12 years ago
This is required for 1.0.8 as per John Lilly and Mike Schroepfer.  

Gavin- Did the fix to bug 327208 fix this bug or do we need a seperate fix for this bug?  If a separate fix, who should work on it?
Flags: blocking-aviary1.0.8? → blocking-aviary1.0.8+
This will be fixed by bug 327208.

*** This bug has been marked as a duplicate of 327208 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Flags: blocking-aviary1.0.8+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.