Last Comment Bug 330121 - datepickers & export code not usable in Lightning on Japanese Win2k
: datepickers & export code not usable in Lightning on Japanese Win2k
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Lightning Only (show other bugs)
: unspecified
: x86 Windows 2000
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-10 18:18 PST by Dan Mosedale (:dmose)
Modified: 2008-02-04 02:06 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Dan Mosedale (:dmose) 2006-03-10 18:18:02 PST
This is due to the fact that the fix for bug 307895 is has not landed in any 1.5.* builds.  Bug 92174 is pretty likely to fix this for the datepicker code; if not, we could move to nsIScriptableDateFormat.  The export code will need some changes.
Comment 1 gekacheka 2006-03-11 10:45:33 PST
(Workaround from bug 306401 comment #4)
> This problem only occurs if '/' is the separator (bug 307895).  
> Workaround: use '-' as the separator.
> (w2k: control panel | regional options | date tab)
Comment 2 Dan Mosedale (:dmose) 2006-03-14 15:56:48 PST
Thanks for pointing that out; I've added this info to the release notes.
Comment 3 Matthew (lilmatt) Willis 2006-09-08 19:41:51 PDT
Since bug 307895 landed, it'd be good to know if this is still an issue.
Comment 4 gekacheka 2006-09-17 08:07:13 PDT
The patch for bug 307895:
- was refused on the 1.8.0 branch, so in TB 1.5.0.x it is not fixed.
- has landed  on the 1.8.1 branch, so in TB 2.0b1   it is fixed.
- has landed  on the trunk branch, so in TB 3.0a1   it is fixed.
Currently, Lightning install.rdf says the minimum version of
Thunderbird is 1.5, so a Lightning release note is still necessary.

Tested on w2k as follows:

A. picker/parser format
 0. start > settings > control panel > regional options > date (tab)
    set SHORT date format to yyyy/MM/dd
    (must have '/' as separator and two digit field last.)
    Restart Thunderbird.
 1. In Lighting, clicking on a date in minimonth such as 31 Aug 2006
    should produce 2006/08/31 in "go" date box.
    (without fix, produces 2006/08/2006)

B. import/export
 1. [was not able to reproduce problem with html export.  Html export
     uses calDateTimeFormatter which uses nsIScriptableDateFormat,
     so it bypasses the bug in Javascript Date.toLocaleFormat.] 

 2. [Was not able to reproduce problem with csv import/export because 
     csv import/export date format is currently not localized
     (bug 301750), but may become a problem in the future when csv date
     format is localized. If so, then the following may be the approach
     to test csv export:]

    Using a calendar with only events, no tasks (avoid bug 336175),
    Calendar | Export Calendar
    Select calendar from dialog if you have more than one.
    Select "CSV" file type, then click ok.
    Look at csv file in text editor.
    Dates should be of form "2006/08/31", not "2006/08/2006".

    [currently it ignores OS localized date format
    and produces 08/31/2006.]

Does this satisfy 'qawanted' flag?  (Should it be removed?)
Comment 5 cmtalbert 2006-10-06 10:44:02 PDT
Spoke with Matt, gekacheka's detailed analysis is sufficient. Removing qawanted flag.
Comment 6 Matthew (lilmatt) Willis 2007-03-23 16:39:10 PDT
Not going to make the 0.5 train.
Comment 7 Simon Paquet [:sipaq] 2008-02-04 02:06:48 PST
Since we do not support TB 1.5 any longer, this is FIXED.

Note You need to log in before you can comment on or make changes to this bug.