If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Edit and Delete options are missing from Calendar tab's context menu

RESOLVED FIXED

Status

Calendar
Lightning Only
--
minor
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Andras Keri, Assigned: Stefan Sitter)

Tracking

Details

(Whiteboard: [cal-ui-review+])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

The option that allows editing and deleting a calendar are missing from the Calendar tab. The option "New.." should also be available. This could lead to remove the three buttons (New, Edit, Delete), thus saving some space on the screen.

Reproducible: Always

Steps to Reproduce:
1. Well. There it is...


Expected Results:  
Enhanced context menu.
(Reporter)

Comment 1

12 years ago
Version: Lightning 0.1 RC2
(Reporter)

Comment 2

12 years ago
build: 2006031011

Comment 3

12 years ago
Created attachment 214787 [details] [diff] [review]
add options

Patch adds New, Edit, and Delete Calendar to the calendar tab panel's context menu.  I'm opposed to removing the buttons, because context menus are inherently less discoverable on Mac.  Then again, I do want to sit down and think about the calendar pane, with an eye towards more elaborate refactoring in the future.
Assignee: nobody → jminta
Status: UNCONFIRMED → ASSIGNED
Attachment #214787 - Flags: first-review?(dmose)
(Reporter)

Comment 4

12 years ago
What a quick fix :)

In my opinion a better order would be:
Edig
Delete
-------
New...
Import
-------
Export
Publish...
(Assignee)

Comment 5

12 years ago
See also Bug 327912 and my proposal at http://wiki.mozilla.org/User:Ssitter:SunbirdMenuRework#Proposal_for_Calendar_context_menu
Maybe we can make the lightning calendar context menu similar.

Comment 6

12 years ago
Let's ask the experts.
'Edit calendar' should be names 'properties' and should be the last option. That's a convetion you see everywhere in windows (and other os-es), so we should follow it. I constanty find myself almost clicking the last item, only to find out that it is something completly different.
(Reporter)

Comment 8

12 years ago
Current proposal is as follows:

----------------------------------
New Calendar...
Delete Calendar
----------------------------------
Import from File...
Export Entire Calendar...
Publish Entire Calendar...
----------------------------------
Reload Remote Calendars
Properties
----------------------------------
(In reply to comment #8)
> Current proposal is as follows:
> 
> ----------------------------------
> New Calendar...
> Delete Calendar
> ----------------------------------

Not sure how you feel about it, but "Rename ..." seems to be a pretty sensible option to have in the context menu as well. I wouldn't think of that action being the same as viewing the calendar properties, and it seems closer to the New/Delete operations.

> Import from File...
> Export Entire Calendar...
> Publish Entire Calendar...
> ----------------------------------

Why "entire"? Is it possible to export or publish a partial calendar? The word seems to be unneccessary.

> Reload Remote Calendars
> Properties
> ----------------------------------

The "Reload Remote Calendars" seems out of place here, in that all the other tasks are specific to the selected object, but this task is globally applied.
Comment on attachment 214787 [details] [diff] [review]
add options

This patch doesn't seem ready for review since there's still a bunch of discussion going on in the bug here.
Attachment #214787 - Flags: first-review?(dmose)
(In reply to comment #9)
> > Import from File...
> > Export Entire Calendar...
> > Publish Entire Calendar...
> > ----------------------------------
> 
> Why "entire"? Is it possible to export or publish a partial calendar? The word
> seems to be unneccessary.

In Sunbird (and sometime soon in Lightning), you can export or publish just the selected events.  Still, using "Entire" here does seem a bit awkward.

> > Reload Remote Calendars
> > Properties
> > ----------------------------------
> 
> The "Reload Remote Calendars" seems out of place here, in that all the other
> tasks are specific to the selected object, but this task is globally applied.

Agreed.  The fact that this context menu happens to be on the entire tab rather than the individual items is a bug, and a bug that we should be trying to hide from user (or, better yet, fixing), I think.
(Assignee)

Comment 12

11 years ago
Created attachment 231430 [details] [diff] [review]
extend Calendars tab context menu

This patch exposes the same context menu commands for Calendars tab as implemented with Bug 327912 for Sunbird.
In addition some IDs are added to several xul elements so that it is easier for future extension authors and theme designers to work with Lightning.
Assignee: jminta → ssitter
Attachment #214787 - Attachment is obsolete: true
Attachment #231430 - Flags: second-review?(jminta)
Attachment #231430 - Flags: first-review?(mattwillis)

Comment 13

11 years ago
I'd like the UI-owners to sign off on bringing these changes into lightning.  I *think* the use-cases are the same here, but they should have final say.
Whiteboard: [cal-ui-review needed]

Updated

11 years ago
Attachment #231430 - Flags: second-review?(jminta) → second-review+
Comment on attachment 231430 [details] [diff] [review]
extend Calendars tab context menu

r1=lilmatt
Attachment #231430 - Flags: first-review?(mattwillis) → first-review+
Whiteboard: [cal-ui-review needed] → [cal-ui-review needed][patch in hand]
(Assignee)

Comment 15

11 years ago
Created attachment 237014 [details] [diff] [review]
extend Calendars tab context menu, v2

Updated patch because the previous one failed to apply after the adding the date text picker control. Carry over r1+ from lilmatt and r2+ from jminta.
Content is the same in described in Comment #12. No l10n impact, only cal-ui-review required (Comment #13).
Attachment #231430 - Attachment is obsolete: true
Attachment #237014 - Flags: second-review+
Attachment #237014 - Flags: first-review+

Updated

11 years ago
Whiteboard: [cal-ui-review needed][patch in hand] → [cal-ui-review+][needs checkin]
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Whiteboard: [cal-ui-review+][needs checkin] → [cal-ui-review+]
You need to log in before you can comment on or make changes to this bug.