ToDo panel should be redesigned

VERIFIED DUPLICATE of bug 372830

Status

--
enhancement
VERIFIED DUPLICATE of bug 372830
13 years ago
11 years ago

People

(Reporter: keria, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Lightning 0.1 RC2 (build: 2006031011)

There is no context menu in the Todo panel in Lightning. The double-click works to edit or to create a task, but there should also be a context menu.

There are no New-Edit-Delete buttons as there are in the Calendars tab. I think it is useless as far as there is a context menu, but this point should be considered carefully.

Columns to be displayed should also be selected. I think that due date and status (in %) is an important information, maybe not for everyone though. The "select columns" icon should be there as usual in Thunderbird.

Reproducible: Always



Expected Results:  
Context menu should be something like this:
 ----------------------------------
 New Task...
 Delete Task
 ----------------------------------
 Status -> 0%/25%/50%/75%/100%
 ----------------------------------
 Hide/Show completed tasks
 Properties
 ----------------------------------

Info about context menu redesign in Wiki: http://wiki.mozilla.org/User:Ssitter:SunbirdMenuRework
I think this should be considered as new users really don't know how to create a task in Lightning. It takes some time to stumble across the double-click feature.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Lightning 0.5
(In reply to comment #2)
> [...] as new users really don't know how to create a task in Lightning [...]

Menu 'File -> New -> Task'

But yes, Lightning needs better task support.
*** Bug 357660 has been marked as a duplicate of this bug. ***
Not going to make the 0.5 train.
Target Milestone: Lightning 0.5 → ---
This has been fixed by adding Sunbirds task list functionality to Lightning.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 372830
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.