crashed on startup [@ nsMsgIdentity::getFolderPref] [@ ntdll!RtlAllocateHeap+0xef]

RESOLVED WORKSFORME

Status

Thunderbird
Account Manager
--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: Telibert Laoc, Unassigned)

Tracking

({crash})

x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

There are two account in my Thunderbird.  There were mails that came in on which I was prompted but I couldn't find in which of the folders these mails went into.  I think I was trying to sift through the mails and trying to group them together when the crash happened.  I still could not open the browser.

Reproducible: Always

Comment 1

13 years ago
> doesn't open anymore except to display the error reporting dialogue box

And what does that dialogue box say?

Which version of TB is this bug reported against?

Have you installed any extensions?  If so, try starting TB in Safe Mode.

Did you try uninstalling and then reinstalling the program?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
    ------- Comment #1 from mcow@well.com  2006-03-13 09:01 PST -------
    > doesn't open anymore except to display the error reporting dialogue box

    And what does that dialogue box say? - PLEASE SEE ATTACHED SCREEN SHOTS ("thunderbird.exe has encountered a problem and needs to close...".  The box appears "status: receiving; sending incident 1 of 1; http://talkback.mozilla.org/spiral-bin/collector.dll"

    Which version of TB is this bug reported against? 1.5.0.1

    Have you installed any extensions?  - YES, FOXCLOCKS, CONTACTS SIDEBAR, MOZILLA CALENDAR, I CAN'T REMEMBER THE TWO OF THREE OTHERS.  If so, try starting TB in Safe Mode.  - I'LL TRY.


Did you try uninstalling and then reinstalling the program? - YES, BUT STILL DID NOT WORK.


    THANKS FOR YOUR REPLY.  I'LL GET BACK TO YOU ON THE SAFE MODE.

Comment 3

13 years ago
(In reply to comment #2)
>     And what does that dialogue box say? - PLEASE SEE ATTACHED SCREEN SHOTS
> ("thunderbird.exe has encountered a problem and needs to close...".  The box
> appears "status: receiving; sending incident 1 of 1;
> http://talkback.mozilla.org/spiral-bin/collector.dll"

OK: that's "TalkBack".  Please do the following: in your TB program directory, find the subdirectory  extensions\talkback@mozilla.org\components
In that directory is a program, talkback.exe  --  run that program, and it will show a list of the talkback information that's been sent back to Mozilla.  Select one of those items, right-click and Copy, and paste the result into this bug -- that will help a lot towards fixing the problem.
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> (In reply to comment #2)
> >     And what does that dialogue box say? - PLEASE SEE ATTACHED SCREEN SHOTS
> > ("thunderbird.exe has encountered a problem and needs to close...".  The box
> > appears "status: receiving; sending incident 1 of 1;
> > http://talkback.mozilla.org/spiral-bin/collector.dll"
> 
> OK: that's "TalkBack".  Please do the following: in your TB program directory,
> find the subdirectory  extensions\talkback@mozilla.org\components
> In that directory is a program, talkback.exe  --  run that program, and it will
> show a list of the talkback information that's been sent back to Mozilla. 
> Select one of those items, right-click and Copy, and paste the result into this
> bug -- that will help a lot towards fixing the problem.
> 

TB16330314H - I hope this is what you are looking for.  BTW, I couldn't figure how to start TB in safemode. Could you show me how?

Thanks again, I've a good number of emails I need to recover from the TB account.  I hope we can get it up and running again.

Comment 5

13 years ago
(In reply to comment #4)
> TB16330314H - I hope this is what you are looking for. 

Yes, that's it.

> BTW, I couldn't figure
> how to start TB in safemode. Could you show me how?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash, talkbackid
Version: unspecified → 1.5

Comment 6

13 years ago
heap corruption

Incident ID: 16330314 
Stack Signature ntdll.dll + 0x106c3 (0x7c9106c3) fc592f4a 
Product ID Thunderbird15 
Build ID 2005120115 
Trigger Time 2006-03-13 17:25:45.0 
Platform Win32 
Operating System Windows NT 5.1 build 2600 
Module ntdll.dll + (000106c3) 
URL visited  
User Comments  
Since Last Crash 8 sec 
Total Uptime 865402 sec 
Trigger Reason Access violation 
Source File, Line No. N/A 
Stack Trace  

ntdll.dll + 0x106c3 (0x7c9106c3) [ntdll!RtlAllocateHeap+0xef]
msvcrt.dll + 0x1c3c9 (0x77c2c3c9) [msvcrt!_heap_alloc+0xe0]
msvcrt.dll + 0x1c3e7 (0x77c2c3e7) [msvcrt!_nh_malloc+0x13]
msvcrt.dll + 0x1c42e (0x77c2c42e) [msvcrt!malloc+0x27]
JS_malloc  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsapi.c, line 1573]
js_AtomizeString  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsatom.c, line 668]
js_Atomize  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsatom.c, line 737]
JS_InternString  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsapi.c, line 4276]
XPCNativeInterface::GetNewOrUsed  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativeinfo.cpp, line 229]
nsJSIID::NewResolve  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/xpconnect/src/xpcjsid.cpp, line 497]
XPC_WN_Helper_NewResolve  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1063]
js_LookupPropertyWithFlags  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsobj.c, line 2675]
js_LookupProperty  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsobj.c, line 2580]
js_GetProperty  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsobj.c, line 2865]
js_Interpret  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c, line 5249]
js_Invoke  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c, line 1197]
js_InternalInvoke  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c, line 1274]
JS_CallFunctionValue  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsapi.c, line 4158]
nsJSContext::CallEventHandler  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1411]
nsGlobalWindow::RunTimeout  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp, line 6298]
nsGlobalWindow::TimerCallback  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp, line 6656]
nsAppStartup::Run  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 151]
main  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mail/app/nsMailApp.cpp, line 62]
kernel32.dll + 0x16d4f (0x7c816d4f)
Keywords: talkbackid
Summary: mail crashed - doesn't open anymore except to display the error reporting dialogue box → mail crashed - doesn't open anymore except to display the error reporting dialogue box [@ ntdll!RtlAllocateHeap+0xef]
Version: 1.5 → unspecified

Updated

13 years ago
Version: unspecified → 1.5
(Reporter)

Comment 7

12 years ago
2117h GMT +7

I still can't open TB in safe mode (no extensions).

Comment 8

11 years ago
crash stack is now different.  bug 372615 also has nsMsgAccountManager::SetSpecialFolders in the stack, but stack isn't the same.

TB32055719
Stack Signature	nsMsgIdentity::getFolderPref dd7a7089
Product ID	ThunderbirdTrunk
Build ID	2007051103
Trigger Time	2007-05-11 19:19:30.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	thunderbird.exe + (00591055)
URL visited	
User Comments	reinstalled thunderbird-3.0a1.en-US.win32.installer then re-ran on commandline thunderbird.exe -safemode; still not success
Since Last Crash	3 sec
Total Uptime	5 sec
Trigger Reason	Access violation
Source File, Line No.	d:\builds\tinderbox\tb-trunk\winnt_5.2_depend\mozilla\mailnews\base\util\nsmsgidentity.cpp, line 293
Stack Trace 	
nsMsgIdentity::getFolderPref  [mozilla/mailnews/base/util/nsmsgidentity.cpp, line 293]
nsMsgIdentity::GetFccFolder  [mozilla/mailnews/base/util/nsmsgidentity.cpp, line 184]
nsMsgAccountManager::SetSpecialFolders  [mozilla/mailnews/base/src/nsmsgaccountmanager.cpp, line 1386]
NS_InvokeByIndex_P  [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp, line 102]
XPCWrappedNative::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2245]


Telibert, please report back after doing the following ... starting at #4 in http://kb.mozillazine.org/Standard_diagnostic_-_Thunderbird do the first 3 items, up to and including 'delete the "chrome" and "extensions" folders'

do you have one profile, with two accounts?
and are the accounts imap or are they pop?
Summary: mail crashed - doesn't open anymore except to display the error reporting dialogue box [@ ntdll!RtlAllocateHeap+0xef] → crashed on startup [@ nsMsgIdentity::getFolderPref] [@ ntdll!RtlAllocateHeap+0xef]

Comment 9

11 years ago
>do you have one profile, with two accounts?
>are the accounts imap or are they pop?

please commennt on the questions above


>And also I could not get Talkback back.

don't care about talkback for now. please give more detail on the steps you did:
* did it crashed after deleting "localstore.rdf" and starting ?
* did it crashed after deleting delete the "chrome" and "extensions" folders and starting ?

Updated

10 years ago
Assignee: mscott → nobody

Comment 10

10 years ago
This crash doesn't exist on crash-stats, nor in talkback TB2018. Reporter "changed laptops and so far, I've not encountered that problem again."

=>WFM
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 11

10 years ago
correction, 3 crashes in last 3 weeks in version 3.0a3 only

bp-c8567bc5-0130-4bb0-b8db-f64912081211  is one

another example bp-1c78d1ba-d1f7-47f0-a992-c97972081202

Signature [Expand]	Source
RtlAllocateHeap	
NtdllpAllocateStringRoutine	
RtlValidSid	
RtlCreateUnicodeStringFromAsciiz	
RegOpenKeyExA	
shlwapi.dll@0xa46d	
shdocvw.dll@0x21786	
shell32.dll@0x70248	
shell32.dll@0x102c10	
shell32.dll@0x102fec	
shell32.dll@0x91437	
shell32.dll@0x2c522	
shell32.dll@0x3ace7	
shell32.dll@0x3219a	
shell32.dll@0x31eca	
shell32.dll@0x31d3c	
shell32.dll@0x31db0	
InternalCallWinProc	
UserCallWinProcCheckWow	
DispatchClientMessage	
__fnDWORD	
KiUserCallbackDispatcher	
shell32.dll@0x31d5a	
SendMessageW	
comctl32.dll@0x1aff0	
comctl32.dll@0x46ea4	
comctl32.dll@0x6cac7	
comctl32.dll@0x47f03	
comctl32.dll@0x4dd03	
comctl32.dll@0x4eca9	
comctl32.dll@0x515bd	
InternalCallWinProc	
UserCallWinProcCheckWow	
DispatchClientMessage	
__fnDWORD	
KiUserCallbackDispatcher	
comctl32.dll@0x50c81	
comctl32.dll@0x6258c	
comctl32.dll@0x6b719	
comctl32.dll@0x46746	
comctl32.dll@0x467a0	
comctl32.dll@0x512c5	
InternalCallWinProc	
UserCallWinProcCheckWow	
DispatchClientMessage	
__fnDWORD	
KiUserCallbackDispatcher	
CAttributeToken::AppendSourceTo	parser/htmlparser/src/nsHTMLTokens.cpp:1640
TestWindowProcess	
SendMessageW	
CUxScrollBar::DoScroll	
xxxMoveThumb	
_TrackThumb	
xxxSBTrackLoop	
_SBTrackInit	
HandleScrollCmd	
_alloca_probe	
_ThemeDefWindowProc	
ThemeDefWindowProcW	
GetPropW	
comctl32.dll@0x50d71	
InternalCallWinProc	
UserCallWinProcCheckWow	
DispatchClientMessage	
__fnDWORD	
KiUserCallbackDispatcher	
nsListBoxBodyFrame::DoInternalPositionChanged	layout/xul/base/src/nsListBoxBodyFrame.cpp:971
RealDefWindowProcW	
DoMsgDefault	
OnDwpNcLButtonDown	
_ThemeDefWindowProc	
ThemeDefWindowProcW	
GetPropW	
comctl32.dll@0x50d71	
InternalCallWinProc	
UserCallWinProcCheckWow	
DispatchMessageWorker	
DispatchMessageW	
IsDialogMessageW	
DialogBox2	
InternalDialogBox	
DialogBoxIndirectParamAorW	
DialogBoxIndirectParamW	
NewGetFileName	
NewGetOpenFileName	
GetFileName	
GetOpenFileNameW	
nsFilePicker::ShowW	widget/src/windows/nsFilePicker.cpp:250
nsFilePicker::Show	widget/src/windows/nsFilePicker.cpp:402
NS_InvokeByIndex_P	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
xptiInterfaceInfo::GetMethodInfo	xpcom/reflect/xptinfo/src/xptiprivate.h:706
XPCCallContext::~XPCCallContext	js/src/xpconnect/src/xpccallcontext.cpp:380
XPC_WN_OnlyIWrite_PropertyStub	js/src/xpconnect/src/xpcwrappednativejsops.cpp:508
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
http://crash-stats.mozilla.com/report/index/22f7b8c7-13a6-48c2-b169-2fd7b2090226

This is top crasher number 2 for TB3.0b2


0  	thunderbird.exe  	nsMsgIdentity::getFolderPref  	nsMsgIdentity.cpp:343
1 	thunderbird.exe 	nsMsgIdentity::GetArchiveFolder 	nsMsgIdentity.cpp:264
2 	thunderbird.exe 	nsMsgAccountManager::SetSpecialFolders 	nsMsgAccountManager.cpp:1394
3 	xpcom_core.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
4 	thunderbird.exe 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:2424
5 	thunderbird.exe 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1583
Flags: blocking-thunderbird3?
Version: 1.5 → Trunk
Ignore #12
Flags: blocking-thunderbird3?
Version: Trunk → 1.5

Comment 14

9 years ago
(In reply to comment #10)
> This crash doesn't exist on crash-stats, nor in talkback TB2018. Reporter
> "changed laptops and so far, I've not encountered that problem again."
> 
> =>WFM

as before ... nowhere to be found on talkback. and also on crash-stats
reclosing WFM
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago9 years ago
Flags: blocking-thunderbird3?
Resolution: --- → WORKSFORME

Updated

9 years ago
Flags: blocking-thunderbird3?
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsMsgIdentity::getFolderPref] [@ ntdll!RtlAllocateHeap+0xef]
You need to log in before you can comment on or make changes to this bug.