If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

It should be possible to save an edited search directly from the Advanced Search form

RESOLVED DUPLICATE of bug 232489

Status

()

Bugzilla
Query/Bug List
--
enhancement
RESOLVED DUPLICATE of bug 232489
12 years ago
10 years ago

People

(Reporter: Prognathous, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
After clicking "Edit Search" and modifying the search form, there is no "Save Edited Search" button. I wasted a lot of time looking for a way to update my search until I realized that I have to actually perform the search to get this option.

It would be nice to either provide such a button in the Advanced Search form itself, or to add a note that explains the flow to a user who clicked "Edit Search". I personally prefer the first option.

Prog.

Comment 1

12 years ago
We actually used to have that, and then we changed it. I'm not sure what the consensus is on adding it back. People seem to request it somewhat frequently.
Version: unspecified → 2.20
I think the current UI is reasonable; we managed a good simplification of the search UI in the last round (from a bunch of fields and checkboxes down to a single Search button, if I remember correctly) and I'd rather not add them back.

It doesn't seem unreasonable for people to test their searches before saving them...

Gerv
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> It doesn't seem unreasonable for people to test their searches before saving
> them...

I had no idea I'm supposed to do that. All I wanted was to update an old email address to a new one, so once I corrected this detail I just looked for that Save Search button. It was nowhere to be found.

I guess Bugzilla is intended for users more intelligent than me...

Prog.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 232489
You need to log in before you can comment on or make changes to this bug.