Scroll bar doesn't scroll the messages

VERIFIED FIXED in M18

Status

SeaMonkey
MailNews: Message Display
P4
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Suresh, Assigned: David Hyatt)

Tracking

Trunk
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
Steps:
1. Click and hold on to mouse to scroll messages one by one in thread pane. The 
messages doesn't scroll. When I release the mouse button the thread pane 
refreshes.

Build and Platform: 2000-03-21-09-M15 and 2000-03-22-08-M15 Linux Commercial 
trunk builds.

Additional Info: Windows seem to work fine.

Comment 1

18 years ago
trudelle - does this belong to your group?

Comment 2

18 years ago
It might, if it exists, but I am unable to reproduce it using today's M15
verification builds (32711) on Linux and Mac. Resolving as wfm; if you see this
again in a current build, please reopen with steps to reproduce.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

18 years ago
trudelle, I could reproduce this using 2000-03-27-11-M15 Linux commercial build. 

Steps to reproduce:
1. Open a mail folder that has more number of msgs. 
2. Click and hold onto mouse to scroll messages one-by-one. (Click on the down 
arrow)
3.  I don't see the messages scroll one-by-one. 
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 4

18 years ago
This is exactly what works for me. Does anyone else see this? Could you please
supply any pertinent details, such as POP/IMAP, Linux kernel version, X xerver,
etc? 
(Reporter)

Comment 5

18 years ago
I tested it on another Linux system and saw the same problem.

- Doesn't matter pop/imap. Able to re-produce in both.
- Linux kernel version - 2.2.12-20smp
- X Server - XFree86 3.3.5-3

Comment 6

18 years ago
That's exactly what I'm running.  What are we doing differently?  Do you
actually have multiple processors installed?
(Reporter)

Comment 7

18 years ago
Nope. Just one Processor. 
If you have time, you can stop by my cube to look at the problem.

Comment 8

18 years ago
I just did, but you weren't there. Perhaps you could stop by here? I believe I 
sit directly beneath you.

Comment 9

18 years ago
Peter, looks like you should own this for now.
Assignee: selmer → trudelle
Status: REOPENED → NEW

Comment 10

18 years ago
assigning to evaughan as p4 for m20, will consider seriously if someone can 
demonstrate a reproducible case.
Assignee: trudelle → evaughan
Priority: P3 → P4
Target Milestone: --- → M20

Comment 11

18 years ago
Am I to infer from trudelle@netscape.com 's last comments that all linux users
are not so plagued?

Comment 12

18 years ago
Not seeing it here. Redhat 6.1 w/all updates, kernel 2.2.14, XFree86 3.3.5,
gtk+/glib 1.2.7.

Comment 13

18 years ago
Again.  Ken and I are running the same setup, yet I experience the problem and
he doesn't.  I had suspected the gtk/glib libraries but he ruled that out.  For
me it renders the mail-news readers unuseable.

Comment 14

18 years ago
When the scrolling doesn't work, try this... Move another window over the
mail/news window briefly, then move it out of the way. Did the thread pane
update? If so, take a look at bug 29808. Could this be a dupe of that one?
(Reporter)

Comment 15

18 years ago
Nominating for beta2 for review by PDT team. I think this bug will affect linux 
users. I'm able to reproduce this on today's debug build on linux.
Keywords: nsbeta2

Comment 16

18 years ago
[nsbeta2+]
Whiteboard: [nsbeta2+]
Target Milestone: M20 → M17

Updated

18 years ago
Blocks: 40158

Comment 17

18 years ago
Tree manages scrolling entirely on its own. Thats hyatt's world[ But I did 
reproduce this on linux. Looks like the redraws are being coelesced where on 
faster platforms they are bieng given time to draw. Once again another bug that 
would be fixed by going to grid.
Assignee: evaughan → hyatt

Updated

18 years ago
Target Milestone: M17 → M18
(Assignee)

Comment 18

18 years ago
fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 19

18 years ago
Linux and Win32 (2000-06-27-09 M17)
Mac (2000-06-26-08 M17)
This problem has been fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.