Pressing Refresh on "multimedia" keyboard tries to reload chrome

VERIFIED FIXED

Status

()

Core
Event Handling
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: Rob Marshall [tH], Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
I have a keyboard with a variety of useless buttons (Stop, Refresh, Back, Forward, etc.), and whilst Refresh works fine with a browser window focused, pressing it with any other window focused (Help viewer, Thunderbird[1], ChatZilla) makes the chrome reload and break in strange ways[2].

In the words of the assertion I got, "don't do that". ;)

[1] Tested Trunk 20060317 and 1.8 20060228
[2] http://bugs.rdmsoft.com/tbrefresh.png
http://talkback-public.mozilla.org/search/start.jsp?search=2&type=iid&id=TB16502999H
(Reporter)

Comment 1

12 years ago
Created attachment 215490 [details] [diff] [review]
add type check before touching webnav

This works, but I'm not sure if it's the best way...
(Reporter)

Updated

12 years ago
Attachment #215490 - Flags: review?(peterv)

Comment 2

12 years ago
*** Bug 349306 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Depends on: 360731
Comment on attachment 215490 [details] [diff] [review]
add type check before touching webnav

Clearing review? since this will be fixed in Bug 360731.
Attachment #215490 - Flags: review?(peterv)
This should be fixed now.
Would be great if someone who has a keyboard with "Refresh" button could verify. Using Firefox, "Refresh" should always reload the current page.
Reload on my Natural Keyboard Pro worked fine when I tested your patch for 360731 previously (see my comment there).
Ok, thanks.
Marking this one fixed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Verified fixed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061201 Firefox/3.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.