Textarea doesn't render content when text is longer than 4095 characters

RESOLVED DUPLICATE of bug 346234

Status

()

RESOLVED DUPLICATE of bug 346234
13 years ago
12 years ago

People

(Reporter: mjuhos, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Textarea doesn't render content when text is longer than 4095 characters.
If text lenght is less 4096 characters, text disapperar sometimes when is text are scrolled.

Reproducible: Always

Steps to Reproduce:
1. Open test case 4096.html (contains 4096 characters in textarea)
2. See textarea content
3. Compare with test case 4095.html


Actual Results:  
Text can be selected but isn't visible.

Expected Results:  
Text will be visible.

This problem was in Firefox 1.0.7 to, but text disappear sometimes, not everytime.
(Reporter)

Comment 1

13 years ago
Created attachment 215643 [details]
Testcase 4096 characters
(Reporter)

Comment 2

13 years ago
Created attachment 215644 [details]
Testcase 4095 characters

Comment 3

13 years ago
Related to/duplicate of (some of) the bugs blocking Meta bug 302294 (e.g. Core bug 35229 comment 33)? Core bug 293940 comment 6 could also be related.

Updated

13 years ago
Blocks: 302294

Comment 4

12 years ago
Reopen if you still see this, but it looks fixed to me. -> Dupe of bug 237085.

*** This bug has been marked as a duplicate of 237085 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

12 years ago
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060811 Minefield/3.0a1

Steps to Reproduce:
1. Select text from text area

Actual Results:  
Text right from selected disappear (see Screenshot).

Expected Results:  
All text will be visible, something will be selected.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 6

12 years ago
Created attachment 233234 [details]
Screeenshot

Comment 7

12 years ago
Sorry, Miroslav. I didn't notice you'd described two bugs here (which are probably related):

The one I noticed is theone where the text vanishes entirely. That is bug 237085, which is now fixed on the 2.0 branch and the trunk (and I think will be landed on the 1.5 branch shortly). That's why I marked it as a duplicate of that one.

However, I now see you also mentioned the one where the text only disappears when you select part of it. This has been spun off as bug 346234. It's probably best to mark this as a duplicate of one or the other.

Cheers.
(Reporter)

Comment 8

12 years ago

*** This bug has been marked as a duplicate of 346234 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.