Last Comment Bug 331276 - saved form is deleted when exiting Firefox
: saved form is deleted when exiting Firefox
Status: RESOLVED WORKSFORME
:
Product: Toolkit
Classification: Components
Component: Form Manager (show other bugs)
: unspecified
: x86 Windows XP
: -- normal with 9 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 18:16 PST by sw1234
Modified: 2008-07-31 04:30 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description sw1234 2006-03-21 18:16:10 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

The saved forms are deleted when I exit from Firefox despite that I have the checkbox 'Clear private data when closing Firefix' unchecked.

Reproducible: Always

Steps to Reproduce:
1.  Enter data into a form and exit site
2.  Verify that the data is still available in the form after ree-entering the site
3.  Close Firefox
4.  Restart Firefox and notice that the saved form is deleted

Actual Results:  
The saved form is deleted

Expected Results:  
The saved form should be available when restarting Firefox
Comment 1 Michael Kraft [:morac] 2006-04-07 12:27:40 PDT
I have easily reproduced this in Firefox 1.5.0.1, but it requires two extensions to be installed.

1. Tab Mix Plus v0.3.0.5 - https://addons.mozilla.org/extensions/moreinfo.php?id=1122
2. Yahoo! Mail Notifier 0.9.9 - https://addons.mozilla.org/extensions/moreinfo.php?id=1264

Other extension combinations may also trigger this, but this is the one I tested with.  For some reason with both of these extensions installed and enabled, form data will not save when Firefox is closed.

Disable either one of the extensions and it will work.  
I'm the author of the 2nd extensions and can't see any reason why this should occur since the extension does not do anything with forms other than display windows.

Steps to recreate:
1. Create new profile (saved forms work)
2. Install Tab Mix Plus and restart (saved forms work)
3. Install Yahoo! Mail Notifier and restart (saved forms do not work)
4. Uninstall or disable Tab Mix Plus and restart (saved forms work)
5. Reinstall or enable Tab Mix Plus and restart (saved forms do not work)
Comment 2 Michael Kraft [:morac] 2006-04-07 13:13:08 PDT
I tracked down the javascript code in my extension that is triggering this.

I have the following lines at the end of a script file embeded in my browser overlay xul file:

if (document.getElementById("content"))
{
   window.addEventListener('load', gYm_notifier.initialize, false);
   window.addEventListener('unload', gYm_notifier.uninitialize, false);
}

It turns out the 'document.getElementById("content")' call is what is causing the problem.  For some reason if this is executed before the window loads, the saved form data no longer saves, but only if the Tab Mix Plus extension is also installed.

I do not know why.
Comment 3 Michael Kraft [:morac] 2006-04-07 14:10:10 PDT
I found another extension that causes this to occur:

Update Notifier 0.1.2  - http://www.longfocus.com/firefox/updatenotifier/

I find this strange because that extension doesn't seem to access document.getElementById() at startup.
Comment 4 Todd Long 2006-04-08 08:58:10 PDT
(In reply to comment #3)
> I found another extension that causes this to occur:
> 
> Update Notifier 0.1.2  - http://www.longfocus.com/firefox/updatenotifier/
> 
> I find this strange because that extension doesn't seem to access
> document.getElementById() at startup.
> 

I'm unable to reproduce this bug with Update Notifier.
Comment 5 Michael Kraft [:morac] 2006-04-08 11:43:10 PDT
Like I mentioned, it seems to rely on combinations of extensions.  So installing just one extension that contains the thing that triggers this flaw won't cause the bug to surface.  So if you have no other extensions that trigger this and then install Update Notifier, everything will still work.  I've duplicated the problem on two different machines with different sets of extensions installed.

The simplest combination I've found is still to install v0.3.0.5 and my Yahoo! Mail Notifier 0.9.9.  If you install my test release version of my extension (http://ymnotifier.mozdev.org) which removes the document.getElementById("content") call at browser startup, then the problem goes away.  I haven't traced into TMP too far to see if it also tries to call document.getElementById at startup or not since it loads a lot of scripts.

I listed all the extensions I have installed on my home machine below.  When the extensions listed as disabled below are disabled saved forms are saved when the browser closes, but if I enable any of the disabled extensions, the saved forms are not saved to the formhistory.dat file (the file is never updated).

Also if I disabled Slashdotter and re-enabled any one of the disabled extensions everything worked.  Slashdotter calls document.getElementById("appcontent") when the browser loads up.

I haven't tested all combinations of the following, but so far it appears that if two or more of the following extensions are installed the problem occurs:

- Slashdotter 1.2.2: http://www.efinke.com/slashdotter.php
- Tab Mix Plus 0.3.0.5: http://tmp.garyr.net
- TargetAlert 0.8.9.5: http://www.bolinfest.com/targetalert/
- Update Notifier 0.1.2: http://www.longfocus.com/firefox/updatenotifier
- Yahoo! Mail Notifier 0.9.9: http://ymnotifier.mozdev.org  (test version doesn't cause the problem)
- Yahoo! Toolbar 1.1.1.20060317: http:/toolbar.yahoo.com/


My installed extensions:

Generated: Sat Apr 08 2006 14:31:42 GMT-0400 (Eastern Daylight Time)
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build ID: 2006011112

Enabled Extensions: [37]
- Adblock Filterset.G Updater 0.3.0.3: http://www.pierceive.com/
- Adblock Plus 0.5.11.3: http://bene.sitesled.com/adblock.htm
- Add Bookmark Here 0.5.5: http://gorgias.de/mfe/
- Add N Edit Cookies 0.2.1.0: http://addneditcookies.mozdev.org/
- AI Roboform Toolbar for Firefox 6.6.6: http://www.roboform.com
- AJAX Yahoo! Mail [Viamatic WebMail++] 0.6: http://viamatic.com/firefox
- All-in-One Gestures 0.17.4: http://perso.wanadoo.fr/marc.boullet/ext/extensions-en.html
- BugMeNot 1.3: http://roachfiend.com
- Customizable Toolbar Buttons 0.1.5: http://www.google.com/search?q=Firefox%20Customizable%20Toolbar%20Buttons
- CustomizeGoogle 0.45: http://www.customizegoogle.com/
- DOM Inspector 1.8.0.1: http://www.mozilla.org/projects/inspector/
- Download Manager Tweak 0.7: http://dmextension.mozdev.org/
- DownloadWith 0.0.7+: http://downloadwith.mozdev.org/
- DSLR Notifier 1.1: http://www.screwedbydesign.com
- Favicon Picker 0.3.0: http://www.google.com/search?q=Firefox%20Favicon%20Picker
- FireBug 0.3.1: http://www.joehewitt.com/software/firebug/
- Flashblock 1.5.1: http://flashblock.mozdev.org/
- FlashGot 0.5.9.993: http://flashgot.net
- Forecastfox 0.8.5.3: http://forecastfox.mozdev.org/
- Greasemonkey 0.6.4: http://greasemonkey.mozdev.org/
- IE Tab 1.0.8: http://ietab.mozdev.org/
- Image Zoom 0.2.5: http://imagezoom.yellowgorilla.net/
- keyconfig 20050908.2: http://mozilla.dorando.at/
- Live HTTP Headers 0.11: http://livehttpheaders.mozdev.org/
- MR Tech Local Install 4.6.1: http://www.mrtech.com/extensions/local_install/
- Net Snippets Toolbar 1.0.4: http://www.netsnippets.com
- Reveal 1.0.6: http://aluminum.sourmilk.net/reveal/
- rikaichan 0.5.6: http://www.polarcloud.com/
- Sage 1.3.6: http://sage.mozdev.org
- Save Image in Folder 0.8: http://www.achimonline.de/mozext/
- SessionSaver .2 0.2.1.030.4: http://adblock.ethereal.net/alchemy.cgi/SessionSaver
- Show Image 0.4.1: http://showimage.mozdev.org/
- Slashdotter 1.2.2: http://www.efinke.com/slashdotter.php
- Talkback 1.5.0.1: http://talkback.mozilla.org/
- User Agent Switcher 0.6.8: http://chrispederick.com/work/firefox/useragentswitcher/
- View Cookies 1.5: http://www.bitstorm.org/extensions/view-cookies/
- WebmailCompose 0.6.6: http://www.jedbrown.net/extensions/

Disabled Extensions: [5]
- Tab Mix Plus 0.3.0.5: http://tmp.garyr.net
- TargetAlert 0.8.9.5: http://www.bolinfest.com/targetalert/
- Update Notifier 0.1.2: http://www.longfocus.com/firefox/updatenotifier
- Yahoo! Mail Notifier 0.9.9: http://ymnotifier.mozdev.org
- Yahoo! Toolbar 1.1.1.20060317: http:/toolbar.yahoo.com/

Total Extensions: 42

Comment 6 Andy 2006-04-08 16:21:28 PDT
Also AIOS and MTLI cause this error. Update Notifier 0.1.3 (pre) doesn`t have this Bug.
Comment 7 Alex 2006-04-11 13:49:07 PDT
I have a weird new problem O.o
My new form data gets deleted too, but only if I enter it, browse websites for a few minutes and restart Firefox then. If I restart right after entering something, it gets saved.

I tracked it down to Greasemonkey 0.6.4 and Tab Mix (Plus), but it's gone if I disable everything in TMP.
Comment 8 Patrick Schoenbach 2006-05-01 09:38:21 PDT
I also get this bug with Tab Mix Plus and Update Notifier installed.
Comment 9 Dak 2006-05-05 17:12:41 PDT
I get this bug (in ff 1.5.0.3), changes in saved form information (i.e., newly entered form data, or deleted form data) does not persist through an immediate restart.... finally pinned it down to update notifier 0.1.2.

Also have Tab Mix Plus 0.3.0.5 and TargetAlert 0.8.9.5 installed, BUT the error doesn't occour with those two enabled and UN disabled.  With everything but UN disabled, the error will occour. UN disabled and everything else enabled = no error.



Comment 10 John Gordon 2006-05-11 17:30:30 PDT
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1)
> Gecko/20060111 Firefox/1.5.0.1
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1)
> Gecko/20060111 Firefox/1.5.0.1
> 
> The saved forms are deleted when I exit from Firefox despite that I have the
> checkbox 'Clear private data when closing Firefix' unchecked.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.  Enter data into a form and exit site
> 2.  Verify that the data is still available in the form after ree-entering the
> site
> 3.  Close Firefox
> 4.  Restart Firefox and notice that the saved form is deleted
> 
> Actual Results:  
> The saved form is deleted
> 
> Expected Results:  
> The saved form should be available when restarting Firefox
> 

I've been experiencing the same bug, and thanks very much to your efforts in tracking down the cause of it, I've been able to rid myself of it by disabling IE Tab 1.0.9.  

My other extensions are Tab Mix Plus 0.3.0.5, Talkback 1.5.0.3, Adblock v.5 d3 *nightly 42, Bookmark backup 0.4.1, NoScript 1.1.4.1, Fasterfox 1.0.3, Resize Search Box 0.0.7, Image Zoom 0.2.4, Add N Edit Cookies 0.2.1.0, and Answers 1.24.
Comment 11 Ian Moody [:Kwan] 2006-06-02 16:16:23 PDT
I'm also getting this bug, and have been since 1.5.0.3.  It seems to actually be incapable of any changes, as deleting a search term from the search box was also not saved (Deleteing all form data from the options menu still works though I believe)

Extensions:
All-In-One Sidebar 0.6.4
Tab Mix Plus 0.3.0.5
Context Search 0.2.1
WellRounded 0.43
Menu Editor 1.2
Organize Status Bar 0.3
Update Notifier 0.1.2
NoScript 1.1.4.1
Cookie Button 0.8.5
Cookie Button in the status bar 0.8.5
Web Developer 1.0.2
Greasemonkey 0.6.4
Stylish 0.3.2
Chatzilla 0.9.73
DOM Inspector 1.8.0.4
Talkback 1.5.0.4
Mozilla XForms 0.5

Disabled:
Console² 0.3.4

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Comment 12 Alexander König 2006-06-18 16:44:04 PDT
I also get this bug with seemingly totally different extensions. I have these installed:


Talkback 1.5.0.4
DOM Inspector 1.8.0.4
Adblock v.5 d3 * nightly 42
PrefBar 3.1.0 (disabled)
Radio_NL Toolbar 1.0.1.14
Search Engine Ordering 0.9.6
SearchPluginHacks 0.1.3
Comment 13 Nick Howitt 2006-06-23 10:22:17 PDT
I can reproduce this with a single extension. Steps to reproduce:

1 - Create new profile
2 - Install TMP 0.3.0.5 and restart
3 - In the Firefox home page, search on something
4 - Search on something else
5 - Restart firefox
6 - In the search box either double click or shift+down to check the form data
7 - Paste something into the search box (I do it by right clicking and pasting) and search
8 - Exit firefox
9 - Repeat step 6. You will see that what you pasted in step 6 has not been remembered. New form history will not be remembered until TMP is disabled when it is OK and it stays OK when it is re-enabled until you paste again.

It appears that pasting something into a form kills form history.

This happens on both my PCs at home.

TMP 0.3.0.5
Ff 1.5.0.4 GB-en
Win XP Pro SP2
Comment 14 Michael Kraft [:morac] 2006-07-06 10:44:59 PDT
Well the good news is that I tested this with the latest trunk nightly (Minefield) and everything works fine; probably because of the switch to using sqlite for saving form data (ie: Places).

The bad news is that it is still broken in the latest nightly of Bon Echo, presumably because sqlite is not yet being used for form data in Bon Echo as it was pushed back to the 3.0 release.

So while this is fixed, the public won't see it until Firefox 3.0 comes out some time in late 2007 (at the earliest).

I guess this can be resolved to whatever bug places is being added under.
Comment 15 Ian Moody [:Kwan] 2006-07-13 16:40:13 PDT
I've discovered that removing the search bar from my toolbar also fixes this problem, both for web page form info and the search bar (if you use the little box that opens from Ctrl+K).
Comment 16 Michael Kraft [:morac] 2006-10-22 16:37:11 PDT
I've been using Firefox 2.0 RC3 and haven't been experiencing this bug on either of the 2 machines despite using the same extensions as with Firefox 1.5.  Even though many of the problem extensions have been upgraded, I'm pretty sure the problem still occurred with Firefox 1.5.   So it looks like this has been fixed (purposely or otherwise).  
Comment 17 Michael Kraft [:morac] 2006-12-27 08:47:12 PST
This seems to be fixed in 2.0.  Either that or it was fixed by all the extension authors, but as it started working after upgrading to 2.0 I think it was fixed in Firefox.
Comment 18 Phil Ringnalda (:philor) 2006-12-29 20:47:41 PST
Probably some shuffling of when things get initialized during startup fixed it, but nothing I can point to to call it fixed, rather than worksforme (and the underlying bug isn't fixed, and according to bz in bug 365134 comment 1 is pretty much just the way XBL and XUL work).

Note You need to log in before you can comment on or make changes to this bug.