Closed Bug 331539 Opened 15 years ago Closed 14 years ago

Failed to navigate cursor in http://www.mozilla.com/ website correctly.

Categories

(Firefox :: Disability Access, defect)

Sun
Solaris
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 334626

People

(Reporter: tim.miao, Unassigned)

Details

(Keywords: access)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050607 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.9a1) Gecko/20060322 Firefox/1.6a1

User failed to move cursor in this webpage backwards in caret browsing mode.

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox and go to http://www.mozilla.com/ website.
2. Press F7 to turn caret browsing mode on, the cursor will stop before 'mozilla'.
3. Press Right arrow key to move focus to Products link.
4. Press Right arrow key to move focus rightwards.
5. Press Shift+Tab to move cursor to 'mozilla' pic again.
6. Press Tab to move cursor to Products link, then press Right arrow key to navigate the cursor through the characters.
7. Press Left arrow key to navigate the cursor backwards.
8. Press Tab to move focus to Firefox1.5 pic.
9. Press Right/Left arrow continuously to browse the webpage.
10. Press Up/Down arrow to browse this website.
Actual Results:  
After step4, user could not navigate the cursor through characters while this can be done according to step6.

After step7, user failed to move cursor backwards. The cursor was blocked.

After step9, cursor will stop before the pic layer on right side and skip the words followed after Firefox1.5 pic.

After step10, the link and words in middle frame will be skipped.

Expected Results:  
Web content should be viewed successfully in caret mode. This bug will effect normal keyboard navigation user slightly, but it will effect blind user seriously, who depends on keyboard navigation and screen reader function.

This bug could be reproduced on vermilion_07/snv_35 with Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.9a1) Gecko/20060322 Firefox/1.6a1.
Keywords: access
OS: Other → Solaris
Hardware: Other → Sun
WFM, Bon Echo nightly 2006-05-15 on Windows.  Please reconfirm your findings with a current nightly build.
Blocks: caretnav
This is yet another example of bug 334626. The items on the top ("Products", "Add-ons", etc.) are floated.

*** This bug has been marked as a duplicate of 334626 ***
No longer blocks: caretnav
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.