Bug 241023 (caretnav)

Caret navigation w/ keyboard [meta bug] (tracking Caret Browsing bugs)

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
15 years ago
2 months ago

People

(Reporter: aaronlev, Unassigned)

Tracking

(Depends on 19 bugs, {access, meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ Used for Orca screen reader solution on Linux ])

Reporter

Description

15 years ago
This is a meta bug for problems moving the caret with the keyboard, in both
editor and caret browsing mode. Caret navigation and HTML editing often suffer
from quirks with the keyboard navigation.

When arrowing through the document with the right arrow key, every character
should eventually be reached.
The caret should never be stuck or sent in the wrong direction
The caret should always be visible on the screen
Reporter

Updated

15 years ago
Alias: caretnav
Reporter

Updated

15 years ago
Depends on: 143996
Reporter

Updated

15 years ago
Depends on: 169297
Reporter

Updated

15 years ago
Depends on: 202163
Reporter

Updated

15 years ago
Depends on: 163839
Reporter

Comment 1

15 years ago
Jessie, there are more bugs with "caret" in the summary. I tried to pick through
them. We should try to avoid filing dupes.
http://bugzilla.mozilla.org/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&short_desc=caret&short_desc_type=allwordssubstr
Depends on: 112418, 181619, 205846, 206697, 209909

Updated

15 years ago
Depends on: 240665

Updated

15 years ago
Depends on: 241034

Updated

15 years ago
Depends on: 241035

Updated

15 years ago
Depends on: 241037

Updated

15 years ago
Depends on: 241038

Updated

15 years ago
Depends on: 241039

Updated

15 years ago
Depends on: 241041

Updated

15 years ago
Depends on: 241042

Updated

15 years ago
Depends on: 241044

Updated

15 years ago
Depends on: 241046

Updated

15 years ago
Depends on: 241049

Updated

15 years ago
Depends on: 241051

Updated

15 years ago
Depends on: 241160
Reporter

Updated

15 years ago
Depends on: 244953
Reporter

Updated

15 years ago
Depends on: 202157
Reporter

Updated

15 years ago
Depends on: 202154

Comment 2

15 years ago
Modified the summary to include the word "Browsing", in order to make this bug
easier to find.

Prog.
Summary: Caret navigation w/ keyboard [meta bug] → Caret navigation w/ keyboard [meta bug] (tracking Caret Browsing bugs)

Updated

15 years ago
Depends on: 250371

Updated

15 years ago
Depends on: 254997

Updated

15 years ago
Depends on: 255000

Updated

15 years ago
Depends on: 254998

Updated

15 years ago
Depends on: 256268

Updated

15 years ago
Depends on: 256252

Updated

15 years ago
Depends on: 256269

Updated

15 years ago
Depends on: 256833

Updated

15 years ago
Depends on: 256835

Updated

15 years ago
Depends on: 257509

Updated

15 years ago
Depends on: 259424

Updated

15 years ago
Depends on: 259455

Updated

15 years ago
Depends on: 259984

Comment 3

15 years ago
*** Bug 254998 has been marked as a duplicate of this bug. ***
Reporter

Updated

15 years ago
Depends on: 260668

Updated

15 years ago
Blocks: 260669

Updated

15 years ago
Depends on: 264284

Updated

15 years ago
Depends on: 269317

Updated

15 years ago
Depends on: 269318

Updated

15 years ago
Depends on: 260667

Updated

15 years ago
Depends on: 264475

Updated

15 years ago
Depends on: 263999

Updated

15 years ago
Depends on: 262236

Updated

15 years ago
Depends on: 269309

Updated

15 years ago
Blocks: 269307

Updated

15 years ago
Blocks: 269306
Reporter

Updated

15 years ago
Depends on: 70154
Reporter

Updated

15 years ago
Depends on: 262497

Updated

15 years ago
No longer blocks: 269307
Depends on: 269307

Updated

15 years ago
No longer blocks: 260669
Depends on: 260669

Updated

15 years ago
No longer blocks: 269306
Depends on: 269306

Updated

15 years ago
Depends on: 237228

Updated

15 years ago
Depends on: 265203
Reporter

Updated

15 years ago
Depends on: 271219
Reporter

Updated

15 years ago
Depends on: 274592

Updated

15 years ago
Depends on: 278197

Updated

15 years ago
Depends on: 278670

Updated

15 years ago
Depends on: 137989

Updated

14 years ago
Keywords: meta

Updated

14 years ago
Depends on: 211847

Updated

14 years ago
Depends on: 300103
Depends on: 205845
Depends on: 300125
Reporter

Updated

14 years ago
Target Milestone: --- → mozilla1.9beta
Reporter

Updated

14 years ago
Whiteboard: [ Used for Gnopernicus screen reader solution on Linux ]

Updated

14 years ago
Depends on: 309009

Updated

13 years ago
Depends on: 334169
Reporter

Updated

13 years ago
Depends on: 331539
Reporter

Updated

13 years ago
Depends on: 335617
Reporter

Updated

13 years ago
Assignee: jessie30 → mats.palmgren
Reporter

Updated

13 years ago
Depends on: 332792
Reporter

Comment 4

13 years ago
*** Bug 338774 has been marked as a duplicate of this bug. ***
Reporter

Updated

13 years ago
Depends on: 337448
Depends on: 334626
Depends on: 346445
Depends on: 347173
No longer depends on: 331539
Reporter

Updated

13 years ago
Depends on: 369855
Reporter

Updated

12 years ago
Depends on: 372624

Updated

12 years ago
Depends on: 376369
Reporter

Updated

12 years ago
Depends on: 381070
Reporter

Updated

12 years ago
Depends on: 384452
Whiteboard: [ Used for Gnopernicus screen reader solution on Linux ] → [ Used for Orca screen reader solution on Linux ]
Mats are you still around? Would be awesome to have your help.

Updated

10 years ago
Depends on: 368346

Comment 6

8 years ago
A nice goal: been able to access all objects in a web page through caret navigation.

Updated

8 years ago
Assignee: matspal → nobody
Closing as part of a batch cleanup of old untouched bugs. This bug hasn't been touched for at least 2000 days.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX

Updated

5 months ago
Depends on: 1521341

Comment 8

5 months ago

(In reply to David Bolter [:davidb] (NeedInfo me for attention) from comment #7)

Closing as part of a batch cleanup of old untouched bugs. This bug hasn't
been touched for at least 2000 days.

Could it be possible to reopen this ? It looks like a fair metabug for caret navigation issues.

Best regards,
Alex.

Flags: needinfo?(mzehe)

There is noone assigned to working on anything related to Caret Browsing in the foreseeable future, so reopening this now doesn't make sense. If at some point somebody will work on that part of the browser again, we can reopen.

Flags: needinfo?(mzehe)

Updated

4 months ago
Depends on: 1526935
You need to log in before you can comment on or make changes to this bug.