Closed Bug 33155 Opened 25 years ago Closed 23 years ago

MLK: POP password dialog

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 103676
Future

People

(Reporter: bruce, Assigned: sspitzer)

Details

(Keywords: memory-leak)

Got this leak out of beard's leak data.

malloc
PR_Malloc
nsAllocatorImpl::Alloc(unsigned int)
nsAllocator::Alloc(unsigned int)
nsStr::Alloc(nsStr&, unsigned int)
nsStr::Realloc(nsStr&, unsigned int)
nsStr::EnsureCapacity(nsStr&, unsigned int)
nsStr::GrowCapacity(nsStr&, unsigned int)
nsString::SetCapacity(unsigned int)
nsString::ToNewUnicode() const
SINGSIGN_PromptPassword
nsWalletlibService::PromptPasswordURL(const unsigned short*, unsigned short**,
const char*, int, nsIPrompt*, int*)
nsWebShellWindow::PromptPassword(const char*, int, const unsigned short*, const
unsigned short*, unsigned short**, int*)
nsMsgIncomingServer::GetPasswordWithUI(const unsigned short*, const unsigned
short*, nsIMsgWindow*, char**)
nsPop3Protocol::GetPassword(char**)
nsPop3Protocol::SendPassword()
nsPop3Protocol::ProcessProtocolState(nsIURI*, nsIInputStream*, unsigned int,
unsigned int)
nsMsgProtocol::OnDataAvailable(nsIChannel*, nsISupports*, nsIInputStream*,
unsigned int, unsigned int)
nsOnDataAvailableEvent::HandleEvent()
nsStreamListenerEvent::HandlePLEvent(PLEvent*)
PL_HandleEvent
PL_ProcessPendingEvents
nsEventQueueImpl::ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
nsMacNSPREventQueueHandler::ProcessPLEventQueue()
nsMacNSPREventQueueHandler::RepeatAction(const EventRecord&)
Repeater::DoRepeaters(const EventRecord&)
nsMacMessagePump::DispatchEvent(int, EventRecord*)
nsMacMessagePump::DoMessagePump()
thanks for logging this, bruce.

I'll take this one.
Assignee: selmer → sspitzer
hmm, we are using an nsXPIDLString in mailnews, so we shouldn't be leaking this.

the leak may be internal to the wallet code, in singsign.cpp

I'll have to investigate.
moving to m16.  not an m15 blocker.  I still need to investigate.
Target Milestone: --- → M16
Triage to M17.  Please add beta2 keyword if this must make beta2.  Please let me 
know if this must be done by M16 feature freeze.
Target Milestone: M16 → M17
it looks like this is in wallet code. reassigning to morse.
Assignee: sspitzer → morse
I'm not so sure wallet is the culprit here.  Yes, wallet (actually 
single-signon to be precise) does allocate a string for the password that was 
requested.  And it returns that string back to the caller of PromptPassword.  
Then it's up to the caller to do what it wants with that string and eventually 
release it.  And the caller in this case is nsPop3Protocol.

Reassigning back to sspitzer.
Assignee: morse → sspitzer
moving to future milestone.
Target Milestone: M17 → Future
accepting all "future" bugs to get them off my "new" bug radar.
Status: NEW → ASSIGNED
The last comment in this bug was 6 months ago. Does anyone know whether this
leak still even exists? (there have been changes to the code you know :-)

If this leak still exists I think we should nominate for 1.0 because - well - we
can dream can't we?
Is it just me, or does
http://lxr.mozilla.org/seamonkey/source/mailnews/base/util/nsMsgIncomingServer.cpp#736
need getter_Copies() or else it will leak? Can someone please verify?
no, a getter_Copies() is not needed there.  (aPassword isn't a nsXPIDLCString.)


Blocks: 92580
No longer blocks: 92580
QA Contact: lchiang → stephend
I can't tell from the stack, but I'm pretty sure this was bug 103676, which
David fixed and I verified.
I haven't seen this leak, so I suspect it's either fixed, or a dup of bug
103676, which is also fixed.
resolving.  

*** This bug has been marked as a duplicate of 103676 ***
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.