[META] footprint issues (tracking)

RESOLVED INVALID

Status

defect
RESOLVED INVALID
18 years ago
3 years ago

People

(Reporter: cathleennscp, Assigned: cathleennscp)

Tracking

(Depends on 3 bugs, {meta})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Assignee

Description

18 years ago
investigate memory bloat problems...
Keywords: meta
Summary: memory bloat issues → memory bloat issues (tracking)

Comment 1

18 years ago
That meta-bug was necessary!! Good thing!

Wouldn't it make the trick to add the bug list resulting from the query on
keyword "mlk" unsolved bugs?

Patrick
Assignee

Comment 2

18 years ago
trace-malloc result for mozilla startup, with a blank page

Type                    Count    Bytes %Total
TOTAL                  115396  5863421 100.00
void*                   23517   943767  16.10
registry-Buffer             1   512000   8.73
xpti-unclassified         250   274080   4.67
unclassified-string      5623   203441   3.47
JSScopeProperty          4460   160560   2.74
gtk-unclassified          928   159473   2.72
nsZipArchive             3438   147662   2.52
JS-Array                 4654   144448   2.46
js_MatchToken            5046   135536   2.31
FrameArena                 31   127565   2.18
JS-script                 866   125423   2.14
nsXULElement             2086   118296   2.02
JS-atom                  4085   114218   1.95
CSSDeclarationImpl       2732   109940   1.88
nsCSSRule                1342   106488   1.82
JSScope                  1140    95760   1.63
nsComponentManagerImpl   2312    90464   1.54
nsTextFragment            360    90106   1.54
JS-unclassified          2110    87392   1.49
nsStaticCaseInsensitiveNameTable   2574    85184   1.45
orkin-unclassified         50    82694   1.41
X-unclassified           3187    82483   1.41
nsCStringKey             2525    77323   1.32
JS-GC-arena                 8    73912   1.26
JS-function              2412    71840   1.23
nsXULAttribute              5    71680   1.22
AtomImpl                 1749    65758   1.12
nsXULAttributes           865    62280   1.06
xptiInterfaceInfo        1409    62232   1.06
nsXMLElement             1137    59124   1.01
RuleHash                 3782    58652   1.00
InMemoryDataSource         92    56074   0.96
nsPersistentProperties   1923    55962   0.95
sscanf                   1504    55325   0.94
xptiManifest             1874    46336   0.79
JS-slots                  818    45536   0.78
nsImageGTK                110    44008   0.75
nsXULPrototypeElement     891    42768   0.73
nsSupportsArray           582    32592   0.56
OTHER                   22918   885039  15.09

Comment 4

18 years ago
Removed double entries in the dependency tree.
No longer depends on: 43589, 53934
Well, if this dependency list was at all useful in the past, it isn't anymore,
since it's now duplicating a bugzilla keyword query.  Leaks are different from
bloat, anyway.  And I really enjoyed deleting the 40 or so spam email messages. :-(

Don't undo it now, though...

Updated

18 years ago
No longer depends on: 34392

Comment 6

18 years ago
*** Bug 96066 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 71066
Assignee

Comment 7

18 years ago
sorry for the large email spam, but I have to clean up this dependency list, to
track memory bloat issues.
Assignee

Updated

18 years ago
Depends on: 104669
Assignee

Updated

18 years ago
Depends on: 56940
Assignee

Updated

18 years ago
Depends on: deCOM
Assignee

Updated

18 years ago
Depends on: 62164
Assignee

Updated

18 years ago
Depends on: 104999
Assignee

Updated

18 years ago
Depends on: 106153
Assignee

Updated

18 years ago
Depends on: 106161
*** Bug 109259 has been marked as a duplicate of this bug. ***
Assignee

Updated

18 years ago
Depends on: 109157, 109218, 110169
Assignee

Updated

18 years ago
Depends on: 112708
Assignee

Updated

18 years ago
Depends on: 113158
Assignee

Updated

18 years ago
Depends on: 113354

Updated

18 years ago
Depends on: 117316
Assignee

Updated

18 years ago
Summary: memory bloat issues (tracking) → footprint issues (tracking)

Updated

18 years ago
No longer depends on: 123728
Assignee

Updated

18 years ago
Depends on: 110163
Assignee

Updated

18 years ago
Target Milestone: --- → mozilla1.0
Assignee

Comment 9

18 years ago
moving tracking/meta bugs out of milestone pools. 
Target Milestone: mozilla1.0 → Future

Updated

17 years ago
Depends on: 120712
Assignee

Updated

17 years ago
Depends on: 171246
Assignee

Updated

17 years ago
Depends on: 171254
Assignee

Updated

17 years ago
Depends on: 170615

Updated

17 years ago
Depends on: 98533, 170983, 170985, 170987

Updated

17 years ago
Depends on: 98284

Updated

17 years ago
Depends on: 72562

Updated

17 years ago
Depends on: 174604

Updated

17 years ago
Depends on: 118455

Comment 10

16 years ago
*** Bug 209310 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Depends on: 212269

Comment 11

16 years ago
Adding META to summary.
Summary: footprint issues (tracking) → [META] footprint issues (tracking)

Updated

15 years ago
Depends on: 196295, 214672, 274391

Updated

15 years ago
Depends on: 285872
reporter's address is dead, bug is rather abandoned (6 years), and indeed duplicative to "footprints" keyword.  does anyone see a need to keep this open?
I'm sure we can mark this Netsacpe tracking bug invalid
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.