Cursor not changed when ctrl held down

VERIFIED DUPLICATE of bug 41748

Status

()

P3
trivial
VERIFIED DUPLICATE of bug 41748
19 years ago
18 years ago

People

(Reporter: hsivonen, Assigned: saari)

Tracking

({platform-parity})

Trunk
mozilla1.0
PowerPC
Mac System 8.0
platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; N; PPC; en-US; m14)
BuildID:    2000032205

The mouse cursor does not change to indicate the availability of the context
menu when ctrl is held down. (Mac only)

Reproducible: Always
Steps to Reproduce:
1. Move the mouse cursor over a window belonging to Mozilla
2. Hold down the ctrl key


Actual Results:  The cursor does not change.

Expected Results:  Expected the mouse cursor to change (like in Finder) to
indicate the availability of the context menu.

Comment 1

19 years ago
This isn't really a bug per se as I don't know whether Mozilla UI intends to
support this 'feature' or not and I don't have access to other platform builds
right now.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

19 years ago
It is a bug, since the standard behavior on Mac OS involves a change in the 

cursor. This bug is not relevant to platforms where the context menu is opened by 

right clicking and Ctrl is used as a shortcut modifier. In fact, it would be a 

bug if holding down Ctrl would change the cursor on those platforms.

Comment 3

19 years ago
This is a context menu or xul keybinding issue.  Trying saari, will let him 
reassign as necessary
Assignee: joki → saari
(Assignee)

Comment 4

19 years ago
Good catch. Yeah, we probably need a platform specific binding to change the 
cursor. Don, should you guys get this? 
Assignee: saari → don

Updated

19 years ago
Keywords: pp
OS: Mac System 8.5 → Mac System 8.0

Comment 5

19 years ago
No. :-)  Seriously, I don't quite understand what needs to be done here.  
(Explain it to the stupid pointy head, please.)
Assignee: don → saari
(Assignee)

Comment 6

19 years ago
Basically you need a platform specific keybinding that is bound to the control
key. That binding gets the current position of the mouse and figures out if
there is a context menu that could be brought up there. That is the part I'm not
sure how to do. But I can learn.
Status: NEW → ASSIGNED
Target Milestone: --- → M16

Comment 7

19 years ago
Moving all bugs that are not dogfood+, nsbeta2+,features, or nsbeta2- to M21
Target Milestone: M16 → M21
(Assignee)

Updated

19 years ago
Target Milestone: M21 → Future

Comment 8

19 years ago
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer

Comment 9

18 years ago
Updating QA Contact.
QA Contact: ckritzer → lorca
(Assignee)

Comment 10

18 years ago
Would be nice to fix for mozilla 1.0
Target Milestone: Future → mozilla1.0
other bug has more info on how to fix.

*** This bug has been marked as a duplicate of 41748 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
VERIFIED.

Comment 13

18 years ago
Uh, *really* VERIFIED this time.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.