Change cursor to context-menu cursor when control key is down

REOPENED
Assigned to

Status

()

P3
enhancement
REOPENED
19 years ago
9 years ago

People

(Reporter: mikepinkerton, Assigned: mikepinkerton)

Tracking

({helpwanted, platform-parity})

Trunk
Future
PowerPC
Mac OS X
helpwanted, platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
When control is held down and a context menu would pop up if the mouse was
clicked, we should change the cursor to the OS context-menu cursor.

request for enancement, fairly minor but platform integration.
(Assignee)

Comment 1

19 years ago
marking future and helpwanted so some enterprising netizen can come along and
make us suck less.
Status: NEW → ASSIGNED
Keywords: helpwanted, pp
Target Milestone: --- → Future
(Assignee)

Comment 2

18 years ago
notes talking to saari:
- extend ESM to be able to give mouse position, button down, etc (while we're at it)
- get the frame for the current mouse point on a control-key-down event
- get its content node
- walk the parent chain looking for popup listeners of type "context"
- if we find one (somehow) change the cursor.
OS: All

Comment 3

18 years ago
This bug will be dependent on bug #26269 which is a Mac-specific bug for 
producing events for modifier-only keys.
Depends on: 26269

Comment 4

18 years ago
This bug will be a duplicate of bug 33229 (or you can mark it the other way
around; whichever one will draw the most attention).
(Assignee)

Comment 5

18 years ago
*** Bug 33229 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
*** Bug 146106 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Proposing this is of Trivial Severity, not Enhancement. Mike, if you agree,
please set it as such.

Updated

16 years ago
OS: All → MacOS X

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets

Comment 8

10 years ago
Resolving WONTIFX as OS X doesn’t change the cursor any more.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Not true! Only some apps do it, which has almost always been the case. As an example, try iTunes.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 10

10 years ago
Hm, true. However, isn’t iTunes a Carbon app? Perhaps this is one of those old Carbon/Cocoa issues. The Finder, I think, is Cocoa, and doesn’t do it.
The Finder is Carbon. This is just an app-specific thing.
You need to log in before you can comment on or make changes to this bug.