drawImage() displaying garbage for transparent png

RESOLVED DUPLICATE of bug 320510

Status

()

Core
Canvas: 2D
RESOLVED DUPLICATE of bug 320510
12 years ago
11 years ago

People

(Reporter: Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com], Unassigned)

Tracking

Other Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

Tested with SeaMonkey 1.0 on WinXP (trunk just crashes - bug 332453 - so I don't know if the bug exists there as well)

I'm using drawImage() to show a transparent png on a canvas and it's giving me garbage on the canvas.  Testcase in a bit.
Created attachment 216918 [details]
transparent PNG
Created attachment 216919 [details]
testcase
Attachment #216919 - Attachment description: testcast → testcase
It looks like a dup of bug 320510 as it's clearly a dup of bug 330478 which has been marked as dup of bug 320510 by the reporter.


Comment 4

11 years ago
This works for me with a current SeaMonkey cairo build. Can you retest with a current Cairo build if you still see this bug (for example with a Firefox trunk build)?
(In reply to comment #4)
> This works for me with a current SeaMonkey cairo build. Can you retest with a
> current Cairo build if you still see this bug (for example with a Firefox trunk
> build)?
> 

I filed on 1.8.0 branch, not trunk.  Resolving as dup based on comment #3.

*** This bug has been marked as a duplicate of 320510 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.