Closed Bug 332595 Opened 14 years ago Closed 14 years ago

Changing calendar in Edit Event dialog has no effect

Categories

(Calendar :: Internal Components, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: jminta)

Details

(Keywords: regression)

Attachments

(1 file)

Changing calendar in Edit Event dialog has no effect

Steps to Reproduce:
1. Create two local calendars, e.g. calendar A and B
2. Create an event in calendar A
3. Open Edit Event dialog and change calendar to B and press OK

Actual Results:
Event still belongs to calendar A

Expected Results:
Event should belong to calendar B

Works in sunbird-0.3a1+.en-US.win32-2006-03-31-07-trunk
Fails in sunbird-0.3a1+.en-US.win32-2006-04-01-08-trunk
Whose responsibility is it to set the .calendar attribute of an item?  The calendar itself when addItem is called, or the event-dialog when calling saveDialog?  The problem is that the transaction's this.mItem.calendar and this.mCalendar don't match.
Attached patch like soSplinter Review
The previous comment, while still perhaps a reasonable question to be answered, is irrelevant to the current bug.  Really, we just need to use the passed in calendar attribute, instead of working off the item.
Assignee: base → jminta
Status: NEW → ASSIGNED
Attachment #217052 - Flags: first-review?(mvl)
Comment on attachment 217052 [details] [diff] [review]
like so

r=mvl
Attachment #217052 - Flags: first-review?(mvl) → first-review+
Patch checked in.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060929 Sunbird/0.3
Status: RESOLVED → VERIFIED
Whiteboard: [litmus testcase wanted]
Litmus testcase 2475 created
Litmus testcase 2615 created
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.