Closed Bug 332741 Opened 18 years ago Closed 18 years ago

should have a way to iterate over default grapheme clusters in text

Categories

(Core :: Internationalization, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 229896

People

(Reporter: dbaron, Assigned: smontagu)

References

(Blocks 1 open bug)

Details

I think we need a way to iterate, both forwards and backwards, over the default grapheme clusters in a string of text.  (Such a mechanism could live on top of a mechanism for iterating over the characters in a piece of (UTF-8 or UTF-16) text.)

For the definition of default grapheme clusters, see:
http://www.unicode.org/reports/tr29/#Grapheme_Cluster_Boundaries
http://www.unicode.org/reports/tr29/#Default_Grapheme_Cluster_Table
and for why this is needed, see the dependent bugs, bug 329069 and bug 332739.

We may want to do some tricks involving glue libraries for this:  we could have the data live in the i18n library, but have a tiny glue library (probably part of unicharutil?) have code that loads the pointer to the data into each library that needs it in the module ctor so we don't need virtual function calls or cross-library calls to load the pointer.
Copying the comment to bug 229896


*** This bug has been marked as a duplicate of 229896 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.