Closed Bug 332792 Opened 15 years ago Closed 13 years ago

Failed to read the last word in each line with caret browsing mode on.

Categories

(Firefox :: Disability Access, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tim.miao, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050607 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9a1) Gecko/20060404 Firefox/1.6a1

Failed to read the last word in each line with caret browsing mode on.

Reproducible: Always

Steps to Reproduce:
1. Launch orca and firefox.
2. Load website: http://sceri.prc.sun.com/desktop//Browser/QA/Test_Case/Accessibility/htmlpage.html
3. Press F7 to open caret browsing mode on.
4. Browse this page with keyboard.
5. Press Ctrl+Right arrow to read word one by one.
Actual Results:  
The last word in a line can not be reported by orca.

Expected Results:  
The last word in a line should be reported by orca.
Keywords: access
OS: Other → Solaris
Hardware: Other → Sun
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: caretnav
OS: Solaris → All
Hardware: Sun → All
I can't access http://sceri.prc.sun.com/. Please attach a testcase to this bug (or at least provide a working URL to a testcase).
Attached file test case
The web page attached.

I think this bug was caused by getCaretOffset or getTextAtOffset in accessible module.
These 2 functions were rewrote.
So this bug may be gone or turned to another bug.

Tim, would you please verify it with latest trunk (3.0)?
This bug is still visible on firefox 3.0( Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9a1) Gecko/20060911 Minefield/3.0a1) and orca 1.0.0.
Blocks: orca
I just tried this with the latest Orca (2.19.3 pre) and the latest Firefox (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a5pre) Gecko/20070521 Minefield/3.0a5pre) and am not seeing this issue.

Tim, can you still reproduce this?
No, I could not reproduce this bug with latest orca and firefox trunk build. Move this bug to fixed status.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Change resolution to WORKSFORME, since we don't know what fixed it.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.