Closed Bug 332796 Opened 19 years ago Closed 16 years ago

Incorrect behavior of up/down arrow keys in unifinder

Categories

(Calendar :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: pavel.zahradnik, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Down arrow key in the event list works well as far as events selected are in the same month (tested with month view), but when I use down arrow key to move to an event in the following month and then I press up arrow key to get back, incorrect event is selected (which is different in the event list and in the calendar/month view). There are more combinations of this bug.

Reproducible: Always

Steps to Reproduce:
1. Switch to month view and click mouse in the event list to select last event of any month.
2. Press down arrow key.
3. Press up arrow key.

Actual Results:  
Event selected in the event list is different from the event selected in the calendar/month view.

Expected Results:  
Event selected in the event list should be the same as the event selected in the calendar/month view - it should be the event which was selected originally by mouse (only if the very last event was originally selected by mouse, after pressing down arrow key and up arrow key the very last but one event should be now selected).

It is also not possible to select more then two events in the event list via keyboard (shift + arrow key). Could be somehow connected.
Confirmed with latest Sunbird Trunk build.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
The bugspam monkeys have struck again. They are currently chewing on default assignees for Calendar. Be afraid for your sanity!
Assignee: base → nobody
I landed some fixes to the unifinder lately.  Can anyone still reproduce this in a nightly from today?
Seems to behave differently in the latest nightly (I don't know whether it is all intended or not) - selecting event in the event list does not change selected event in month view as far as the event selected in the event list can be seen in the month view. But when the next event in the event list is selected by down arrow key, month view is changed (which would be OK) but event in the event list is not changed (actually it is changed but then the focus gets back to the previous event automatically).

Similar happens if you have e.g only two events that cannot be displayed in one month view, and you select the first event in the event list and then press End key - month view is changed to display the second event (which would be OK) but in the event list the first event remains selected (actually it is changed to the last event and then the focus gets back automatically).

Well, the first thig is that Up/Down/Home/End/PageUp/PageDown keys do not work in the event list as ordinary user would expect - pressing Down key should select next event in the event list, pressing End key should select last event in the event list and so on. The second thing is that month view does not always correspond with event selected in the event list - selecting event in the event list should refresh month view to display (and focus) this event.
Component: Internal Components → Sunbird Only
Target Milestone: --- → Sunbird 0.3
Not going to make the 0.3 train.
Target Milestone: Sunbird 0.3 → Sunbird 0.4
QA Contact: base → sunbird
Not going to make the 0.5 train.
Target Milestone: Sunbird 0.5 → ---
Component: Sunbird Only → General
QA Contact: sunbird → general
Summary: Incorrect behaviour of Up/Down arrow keys in event list → Incorrect behavior of up/down arrow keys in unifinder
Version: Trunk → unspecified
Behavior of Up/Down arrow keys is still buggy in Lightning 0.9. After pressing any of these keys the focus is lost from unifinder.
Marking as fixed by Bug 348481 (regarding latest bug description update in comment 7)
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
(In reply to comment #8)
> Marking as fixed by Bug 348481 (regarding latest bug description update in
> comment 7)

The issues from comment#0 and comment#4 are not fixed for me. -> REOPENING
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
WFM now using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081111 Lightning/1.0pre Shredder/3.0b1pre.
Status: REOPENED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.