Extensions are only showing 1 author instead of all

VERIFIED FIXED in 1.0

Status

--
major
VERIFIED FIXED
13 years ago
3 years ago

People

(Reporter: bugzilla-mozilla-20000923, Assigned: cameron)

Tracking

({regression})

regression

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
https://addons.mozilla.org/a/16/

Only shows "James Ross" as an author, when in fact there are two others: "Samuel Sieb" and "Robert Ginda". The same problem seems to occur for other extensions too.
Assignee: morgamic → clouserw
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Updated

13 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 1

13 years ago
This is not fixed anywhere but the extension details page.

I've found the following other pages that are broken:
  - all search results
  - previews & screenshots page
  - comments
  - add a comment page
  - version history

There is also the unfair treatment of the first author for use in the "About the author" link on the left-side menu. I'll spin that into another bug if you want, as it's probably not really the same.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 2

13 years ago
It's also coccured to me that the pages are all showing the same content - so it really ought to be shared code (meaning you'd only have had to fix it once ;) ).
The updated getter for user info that retrieves multiple user info isn't in the same variable, so the views just need to be updated but the data is probably there.
(In reply to comment #1)
> This is not fixed anywhere but the extension details page.
> 
> I've found the following other pages that are broken:
>   - all search results
>   - previews & screenshots page
>   - comments
>   - add a comment page
>   - version history
> 
> There is also the unfair treatment of the first author for use in the "About
> the author" link on the left-side menu. I'll spin that into another bug if you
> want, as it's probably not really the same.
> 

I guess I was pretty tired last night, but it's fixed on all the pages above now.  If the addon has multiple authors, the nav expands out to list them all.  I think it worked out pretty well.  Anyway, it's in cvs, should be up soon, etc.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

13 years ago
Verified. 


New bug caused by changes - Bug 333128
Status: RESOLVED → VERIFIED
(Assignee)

Comment 6

13 years ago
[11/04/2006 7:49 AM] <crafteh> not sure what bug it was ... but only one author is shown for extensions with multiple authors on the report comments page
[11/04/2006 7:49 AM] <crafteh> i think the other instances of it were fixed
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

13 years ago
Crafteh: What do you mean by "the report comments page" ?

Comment 8

13 years ago
https://addons.mozilla.org/ratecomment.php

Sorry, I guess it was the rate comments page. Rate a comment helpful or not helpful, and the resulting page only lists one author (try Forecastfox as an example).
(Assignee)

Comment 9

13 years ago
Created attachment 217973 [details] [diff] [review]
Fix to ratecomment.php

Blargh! How many times does this code appear? hehe :)
Assignee: clouserw → em6icu202
Status: REOPENED → ASSIGNED
Attachment #217973 - Flags: first-review?(clouserw)
(In reply to comment #9)
> Created an attachment (id=217973) [edit]
> Fix to ratecomment.php
> 
> Blargh! How many times does this code appear? hehe :)
> 

Patch is in cvs.  One of these days, this bug will be fixed. :(
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Attachment #217973 - Flags: first-review?(clouserw) → first-review+
(Assignee)

Updated

13 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Comment 11

13 years ago
Organising bugs. Sorry for the bugspam.
Version: unspecified → 2.0
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.