Fix comment sorting, persistence of sort

VERIFIED FIXED in 1.0

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
12 years ago
2 years ago

People

(Reporter: James Ross, Assigned: morgamic)

Tracking

({regression})

regression

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
https://addons.mozilla.org/firefox/16/comments/

The comments are in a completely random order; instead, they should be sorted by date (within the "helpfulness" rating).

Comment 1

12 years ago
Should be sorted by most recent

Comment 2

12 years ago
(In reply to comment #1)
> Should be sorted by most recent

Why?

(Reporter)

Comment 3

12 years ago
Per my original comment, they should be sorted most recent /within the same helpfulness group/, i.e. sort by helpfulness first and then date as a secondary sort. This will at least stop completely outdated coments appearing as if they are new.

Comment 4

12 years ago
James: I agree with you, but I'm not sure if Kurt wants to do away with helpfullness and just use date.
(Reporter)

Comment 5

12 years ago
Kurt, if you do want to do away with helpfulness, that is a seperate bug.

Comment 6

12 years ago
Should definently be sorted by helpfulness but be sorted by most recent also. 

Because old comments refer to older versions which if you got a bad comment for that version not working and you have since updated that comment from a year ago wouldnt appear first. Changing summary to refelect this.
Summary: Comments are unsorted beyond "helpfulness" → Comments should be sorted by newest and helpfulness

Comment 7

12 years ago
Sorting by anything other than newest on the description page is very confusing.

- developer replies are out of context (actually they are completely missing now WTF?)
- comments refering to features/bugs in previous versions should not appear before relevent (more recent) comments

A

Comment 8

12 years ago
(In reply to comment #7)
> Sorting by anything other than newest on the description page is very
> confusing.
> 
> - developer replies are out of context (actually they are completely missing
> now WTF?)

Developers can use the developer's comments section.

Remember that the comments are not designed to be for support.

Comment 9

12 years ago
(In reply to comment #8)
> Developers can use the developer's comments section.
> 
> Remember that the comments are not designed to be for support.
> 
Then what is the "add a comment without ranking" button for?

The comment at the top of one of my extensions is "Great extension, would be better if it did X".  I added a reply (4 months ago) explaining that it did this already.  

Using the developers comments to explain/rebut outdated comments that appear on the description page is not a workable solution. A better solution for me at this point is to add a "comment system is completely hosed, please ignore" comment, which I've done, but I don't really like it as a long term solutions.

Like it or not people ask quesions and give suggestions in the comments.  Unless you associate them with a release, showing them out of order severly reduces their value.



Yes, please sort by date by default.  I'm sure the change was well-intentioned, but it's just awful.
(Assignee)

Comment 11

12 years ago
Okay -- thanks for the comments guys.  Would a defaut sort of most helpful but sorted by date after that help?

The reason for the most helpful sort was so users get the most useful comments first.  I think this is relatively important... what do you think?

Would adding the date sort after the most helpful be a proper compromise?

Also, sorry for the headache -- we will get this fixed up right w/ your help and feedback.  :)  You're right, I didn't mess it up on purpose... :)
Status: NEW → ASSIGNED

Comment 12

12 years ago
(In reply to comment #11)
> Okay -- thanks for the comments guys.  Would a defaut sort of most helpful but
> sorted by date after that help?

Not really.

> 
> The reason for the most helpful sort was so users get the most useful comments
> first.  I think this is relatively important... what do you think?

No.  "there is a big bug in this release, install the previous one" is a very helpful comment.  But there's no way it should stay at the top of the list forever.  

I don't think the concept of helpfulness is appropriate at all.  It's great for book reviews, because the contents of the book remain static.  Extensions don't.

Being able to sort by lowest/highest rank is kind of handy, but we really need some annotation against the comment showing the release number or this can be completely misleading.

Comment 13

12 years ago
Gradual helpfulness decrease over time is what I'd suggest, but that just sounds hard :s
(Assignee)

Comment 14

12 years ago
Okay, so I'll change the default sort to newest, which will be sorted by date then helpfulness.  Then if people want to see helpful comments (as rated by other users) they can use the sort.

Thanks for the comments.

Comment 15

12 years ago
(In reply to comment #14)
> Okay, so I'll change the default sort to newest, which will be sorted by date
> then helpfulness.  Then if people want to see helpful comments (as rated by
> other users) they can use the sort.
> 

Sounds good.  Though I'd still like to see my replies in the list...

You know that sort doesn't work now.  Right?

I change the sort type, but when I go to the next page it reverts back to the default.

Comment 16

12 years ago
(In reply to comment #15)
> You know that sort doesn't work now.  Right?
> 
> I change the sort type, but when I go to the next page it reverts back to the
> default.

See Bug 333108

"I don't think the concept of helpfulness is appropriate at all.  It's great for
book reviews, because the contents of the book remain static.  Extensions
don't."

I absolutely agree. If you are keeping this functionality, please at least consider tagging each comment with an associated extension version number.
(Assignee)

Updated

12 years ago
Summary: Comments should be sorted by newest and helpfulness → Fix comment sorting, persistence of sort
(Assignee)

Comment 18

12 years ago
*** Bug 333108 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 19

12 years ago
Created attachment 217626 [details] [diff] [review]
Patch for fixing sorting (committed, it's pretty straightforward).

Getting this fixed before too many people riot.  Verify in about an hour.  Thanks.
(Assignee)

Updated

12 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 20

12 years ago
There's something odd going on; the comments page is only /sometimes/ remembering the sort order in the Prev/Next links, and - more importantly - it is still defaulting to "Most helpful" first.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 21

12 years ago
It seems that the pages that are correct also show the extension's rating at the top, and the broken pages don't. I can only think the cache is being silly...
(Assignee)

Comment 22

12 years ago
I think this is probably attributed to a node not being restarted.  I'll try to figure this out w/ the sysadmins.  Thanks.
Status: REOPENED → ASSIGNED
(Assignee)

Comment 23

12 years ago
Okay -- inconsistencies fixed.  APC requires a graceful restart for apache -- and that wasn't done last night.

Check now -- thanks.  :)
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 24

12 years ago
Looks good. :)
Status: RESOLVED → VERIFIED

Comment 25

12 years ago
Organising bugs. Sorry for the bugspam.
Version: unspecified → 2.0
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.