Thunderbird freezes while searching in a folder with lots of messages ( search bar )

RESOLVED FIXED

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED FIXED
11 years ago
8 years ago

People

(Reporter: César, Assigned: Bienvenu)

Tracking

({fixed1.8.0.8, fixed1.8.1, verified1.8.1.3})

unspecified
x86
Linux
fixed1.8.0.8, fixed1.8.1, verified1.8.1.3
Bug Flags:
blocking1.8.0.8 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.0.1) Gecko/20060313 Debian/1.5.dfsg+1.5.0.1-4 Firefox/1.5.0.1
Build Identifier: version 1.5 (20051201) http://www.mozilla.com/products/download.html?product=thunderbird-1.5&os=linux&lang=en-US

I have a folder containing lots of emails (around 4000 messages).
If I try to search in this folder using the search bar, Thunderbird freezes (it is not responsive anymore to any click/keypress, and it doesn't redraw if I change the size of the window or switch to another window).

If I search using the tool Edit => Find => Search Messages, it works fine (it finds the messages very fast, indeed).

It happens with Mozilla's Thunderbird version (version 1.5 20051201) and also with Debian's Thunderbird version (1.5-4).


Reproducible: Always

Steps to Reproduce:
1. Click on a folder with tons of messages
2. Search some text using the search bar

Actual Results:  
Thunderbird freezes. It is not responsive anymore, and top shows 99% of CPU usage.
(Reporter)

Updated

11 years ago
Severity: normal → critical

Comment 1

11 years ago
First, it seems this bug has to do with Bug 331014.

Second, I can confirm it in Thunderbird 1.5.0.5 (20060725), on SuSE 10. I tried searching two news threads (on news.gmane.org):
gmane.comp.lang.haskell.general (12309 messages)
gmane.comp.lang.haskell.cafe (14453 messages)
The first one always searches fine (through the search bar), the second one always hangs. Using the search tool as described by previous poster works for both folders.

One thing I noticed is that the thread that hangs has some messages in it, that have unreadable subjects - all small question marks in black ovals. One such message on haskell.cafe is on 04/20/2002 09:07AM.

Cheers,
  Misha

Comment 2

11 years ago
I just realised that the other folders also have unreadable messages, so this shouldn't be a problem.

  Misha
(Assignee)

Comment 3

11 years ago
Created attachment 239235 [details] [diff] [review]
proposed fix
[Checkin: Comment 8 (*2) & 11]

handle the bad threading.
Assignee: mscott → bienvenu
Status: UNCONFIRMED → ASSIGNED
Attachment #239235 - Flags: superreview?(mscott)
(Assignee)

Comment 4

11 years ago
Created attachment 239252 [details] [diff] [review]
fix root cause of problem
[Checkin: Comment 8 (*2) & 11]

ignore it when a message says it's a child of itself
Attachment #239252 - Flags: superreview?(mscott)

Updated

11 years ago
Attachment #239252 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 5

11 years ago
N.B., the first patch is required for people who already have corrupt db's...

Comment 6

11 years ago
Comment on attachment 239235 [details] [diff] [review]
proposed fix
[Checkin: Comment 8 (*2) & 11]

I got interrupted before I could finish looking at this one too. :)

Comment 7

11 years ago
Comment on attachment 239235 [details] [diff] [review]
proposed fix
[Checkin: Comment 8 (*2) & 11]

bleh, forgot to set the flag.
Attachment #239235 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 8

11 years ago
fixed on trunk and branch
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
(Assignee)

Updated

11 years ago
Flags: blocking1.8.0.8?
(Assignee)

Updated

11 years ago
Attachment #239235 - Flags: approval1.8.0.8?
(Assignee)

Comment 9

11 years ago
Comment on attachment 239252 [details] [diff] [review]
fix root cause of problem
[Checkin: Comment 8 (*2) & 11]

this patch prevents the corruption from happening; the previous patch handles the already corrupt threading. The other code that iterates over threads already handle this case. We'll let this bake on the trunk and branch, but requesting approval while I remember...
Attachment #239252 - Flags: approval1.8.0.8?
Flags: blocking1.8.0.8? → blocking1.8.0.8+
Comment on attachment 239235 [details] [diff] [review]
proposed fix
[Checkin: Comment 8 (*2) & 11]

approved for 1.8.0 branch, a=dveditz for drivers
Attachment #239235 - Flags: approval1.8.0.8? → approval1.8.0.8+
Attachment #239252 - Flags: approval1.8.0.8? → approval1.8.0.8+
(Assignee)

Comment 11

11 years ago
fixed in 1.8.0 branch
Keywords: fixed1.8.0.8

Comment 12

11 years ago
I have not been able to reproduce this, so if anyone seeing this problem can test a recent nightly build (http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/) and verify that this is fixed, that will be great!  Please update the fixed1.8.x keyword(s) with verified1.8.x.  Thanks!

Comment 13

11 years ago
gmane.comp.lang.haskell.cafe searches fine in Thunderbird 1.5.0.7 (20061023). I don't have permission to change bug status however.
If someone (the reporter or another person who has seen the bug) can please verify the fix from a candidate build in this directory, that would be great - ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/1.5.0.8-candidates/rc1/

Updated

11 years ago
Blocks: 360409
No longer blocks: 360409
Depends on: 360409

Updated

11 years ago
Blocks: 360409
No longer depends on: 360409
No longer blocks: 360409
Depends on: 360409
Tried several types of searches in folders with many messages >5000, threaded and unthreaded, and I don't see Tbird 2 freezing. 

Updated

10 years ago
Keywords: verified1.8.1.3
Attachment #239252 - Attachment description: fix root cause of problem → fix root cause of problem [Checkin: Comment 8 (*2) & 11]
Attachment #239235 - Attachment description: proposed fix → proposed fix [Checkin: Comment 8 (*2) & 11]
Duplicate of this bug: 358441
You need to log in before you can comment on or make changes to this bug.