RSS feeds with blank titles cause Thunderbird to hang on "Verifying the feed..."

RESOLVED DUPLICATE of bug 347922

Status

MailNews Core
Feed Reader
RESOLVED DUPLICATE of bug 347922
12 years ago
3 years ago

People

(Reporter: Tom Hessman, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20060321 Firefox/2.0a1
Build Identifier: Thunderbird version 1.5 (20051201)

When attempting to add a new RSS feed to Thunderbird which has a blank title (i.e. <title></title>), the "Manage Subscriptions" window gets stuck on "Verifying the feed...".  Eventually, when you start doing other things or try to close Thunderbird, it asks you if you really want to cancel subscribing to the feed.  It never does successfully add the feed.

Reproducible: Always

Steps to Reproduce:
1. Open the "Manage Subcriptions" dialog, click the "Add" button.
2. In the box for "Feed URL", enter the URL of a feed that has a blank title (such as http://www.pasekandpaul.com/Site/News/rss.xml)
3. Click OK.

Actual Results:  
Thunderbird gets stuck at "Verifying the feed", and never creates a folder for it or downloads the articles.

Expected Results:  
Thunderbird should verify the feed, create a folder for it, and download the feed's current articles.

I suspect the problem is that Thunderbird needs the title to set up the feed, and it doesn't know what to do with a blank title.  I first saw this bug on a Mac with Thunderbird 1.5, and have also reproduced it on Windows 2000 with the 2006-04-05 1.8 branch build of Thunderbird.  I have also tried experimenting with my own feed, and have confirmed that blank title seems to be the problem.

Comment 1

12 years ago
Fix will be in TB 1.5.0.2.

*** This bug has been marked as a duplicate of 315600 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

12 years ago
This bug was not fixed by the fix for bug 315600...the above feed still can't be added to Thunderbird 1.5.0.4 (or 1.5.0.2...and I'm on Mac OS X for the record).  The feed is valid, except for the warnings on the blank title.  Because the testcase for bug 315600 now works, but this one doesn't, I'm wondering if it's a different issue, though I can't imagine what.

I'm also having trouble adding the feed located at http://tv.stapleshigh.net/rss.php, which I was able to add a while ago but I can't anymore in TB 1.5.0.4.  (Note that the server is currently down, but it should be up again soon).

Reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

12 years ago
Reproduced with TB 2a1-0604, Win2K.

Both feeds listed have minor issues ("valid, but may cause problems") but the problems are different:
 - the original test feed currently has two empty <title></title> pairs.
   (The test feed from bug 315600 had a single empty pair.)
 - the feed in comment 2 is complaining about HTML being included in the
   <description> tag.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Comment 4

12 years ago
I experienced the same hanging. Thunderbird should at least time out!  One URL I tried was totally invalid. This website had linked their [XML] icon to another web page, instead of directly to a feed as I expected:

 http://www.desktoplinux.com/backend/index.html

Comment 5

12 years ago
same problem with some microsoft msdn blogs like http://blogs.msdn.com/texttospeech/atom.xml

--> feedvalidator.org return these warnings

Warning

This feed is valid, but may cause problems for some users. We recommend fixing these problems.

    *

      line 17, column 342: title should not contain HTML unless declared in the type attribute: &quot; (4 occurrences) [help]

          ... t;A thread is a happy husband?&amp;quot;</title><link rel="alternate" ty ...
                                                       ^

    *

      line 18, column 0: style attribute contains potentially dangerous content: mso-ansi-language (2 occurrences) [help]

          &lt;P class=MsoNormal style="MARGIN: 0in 0in 0pt"&gt;&lt;SPAN lang=FR-CA sty ...

Comment 6

11 years ago
It was pointed out at bug 347922 that feeds with an empty <title> are also causing errors to appear during the attempt to subscribe -- it doesn't happen immediately, but after some seconds, perhaps in response to a timeout:
=========================
Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIRDFService.GetLiteral]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger-newsblog/content/Feed.js :: anonymous :: line 219"  data: no]
Source File: chrome://messenger-newsblog/content/Feed.js
Line: 219
=========================
The above seen in 2.0pre-0302.

Comment 7

11 years ago
This was fixed in bug 347922. Feeds seems to be working with todays build.
Status: NEW → RESOLVED
Last Resolved: 12 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 347922

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core

Comment 8

3 years ago
The problem with a empty title Field persist in Thunderbird 31.5.0.
You need to log in before you can comment on or make changes to this bug.