If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Adding ATOM feed hangs forever for validation

RESOLVED FIXED in Thunderbird 3

Status

MailNews Core
Feed Reader
RESOLVED FIXED
11 years ago
3 years ago

People

(Reporter: Dwaine Gonyier, Assigned: Magnus Melin)

Tracking

({verified1.8.1.3})

1.8 Branch
Thunderbird 3
verified1.8.1.3

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Thunderbird version 1.5.0.5 (20060719)

I attempted to add the following feed to Thunderbird
http://guildcast.com/show/?feed=atom
and the subscription window would stay in the validating feed state forever until I close it.

The following error shows up in the Javascript console:
Error: someHTML has no properties
Source File: chrome://messenger-newsblog/content/feed-parser.js
Line: 490


Reproducible: Always

Steps to Reproduce:
See details for basic procedure to reproduce

Actual Results:  
subscription manager is stuck in validating feed state

Expected Results:  
Feed subscription should succeed

This feed operates normally when added as a live bookmark in Firefox 1.5.0.6 for windows on the same PC.
(Reporter)

Updated

11 years ago
Version: unspecified → 1.5
(Assignee)

Comment 1

11 years ago
Confirmed on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060809 Thunderbird/2.0a1 ID:2006080904

The error is from here:

  stripTags: function(someHTML) 
  {
    return someHTML.replace(/<[^>]+>/g,"");
  },
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Version: 1.5 → 2.0

Comment 2

11 years ago
FWIW, the feed reports as Atom 0.3, which is no longer supported by feedvalidator.org or the W3C feed validator.

Comment 3

11 years ago
Same Problem.
Thunderbird subscription manager is stuck in validating feed state. TB1.5
Firefox is also not able to load the dynamic bookmark. FF1.5
(Reporter)

Comment 4

11 years ago
(In reply to comment #3)
> Same Problem.
> Thunderbird subscription manager is stuck in validating feed state. TB1.5
> Firefox is also not able to load the dynamic bookmark. FF1.5
> 

I still have this same problem with the same feed URL in Thunderbird 1.5.0.10
Firefox 1.5.0.11 has no problems with is feed and loads it just fine...

(Reporter)

Comment 5

11 years ago
Actually, the same site offers an alternative feed for the same information:

http://guildcast.com/show/?feed=rss2

Unfortunately, subscribing to this feed in Thunderbird also hangs forever and the folllowing javascript error is logged in Thunderbird:

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIRDFService.GetLiteral]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger-newsblog/content/Feed.js :: anonymous :: line 219"  data: no]
Source File: chrome://messenger-newsblog/content/Feed.js
Line: 219


Firefox 1.5.0.10 (note that my previous comment has a typo for the firefox version... should be 1.5.0.10 there as well) has no problems with this alternate feed.

(Assignee)

Comment 6

11 years ago
Created attachment 257849 [details] [diff] [review]
proposed fix

Don't hang on verifying when the feed has a blank title element.
Assignee: mscott → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #257849 - Flags: review?(mscott)

Comment 7

11 years ago
That patch is really for bug 332910, no?  Is the original Atom feed from comment 0 also failing because of a blank title?
(Assignee)

Comment 8

11 years ago
Yeah, that sounds like a dupe... (or the other way around)
Both checks this patch adds are needed when title is blank.

Tried http://guildcast.com/show/?feed=rss2 and http://guildcast.com/show/?feed=atom

Comment 9

11 years ago
Comment on attachment 257849 [details] [diff] [review]
proposed fix

I'm going to sneak this into tb2 as well since we haven't tagged yet.
Attachment #257849 - Flags: review?(mscott)
Attachment #257849 - Flags: review+
Attachment #257849 - Flags: approval-thunderbird2+

Comment 10

11 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1.3
Resolution: --- → FIXED
(Assignee)

Updated

11 years ago
Duplicate of this bug: 332910
Verified fixed for 1.8.1.3 using Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3 ID:2007030919 

Tested with the 2 Feeds from comment #8 

Feeds were added and working fine.
Keywords: fixed1.8.1.3 → verified1.8.1.3
Both feeds from comment 8 don't work for me. Using Linux 2.0.0.14 (20080502) version on Kubuntu. Could somebody try it with Thunderbird NOT from Ubuntu package but from source to find out if it is due to the way it is packaged for Ubuntu?
(In reply to comment #13)
> Both feeds from comment 8 don't work for me. Using Linux 2.0.0.14 (20080502)
> version on Kubuntu. Could somebody try it with Thunderbird NOT from Ubuntu
> package but from source to find out if it is due to the way it is packaged for
> Ubuntu?
> 
Sorry about confusion, it's an issue with my profile.

It can't be reproduced with new empty profile, but happens when I configure several mail accounts with empty profile and then try to subscribe to, in my case RSS feed with empty title tag. It doesn't occur if I serve the same feed locally from Apache with title element that is not empty.
This bug is still somehow triggered when the title is empty, but not always.
It triggers:

Viga: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.createSubfolder]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger-newsblog/content/FeedItem.js :: anonymous :: line 209"  data: no]
Lähtefail: chrome://messenger-newsblog/content/FeedItem.js
Rida: 209 

Any suggestions or debugging instructions?
(Assignee)

Comment 16

10 years ago
Not really, but file a new bug if you can figure out how to reproduce. This bug is closed.
Target Milestone: --- → Thunderbird 3

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Version: 2.0 → 1.8 Branch

Updated

9 years ago
Component: Feed Reader → RSS
Product: MailNews Core → Thunderbird
Version: 1.8 Branch → 2.0

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Version: 2.0 → 1.8 Branch

Comment 17

3 years ago
The problem with a empty title Field persist in Thunderbird 31.5.0.

Comment 18

3 years ago
Niels, this is a very old, fixed bug. If you have an issue in a current version of Thunderbird, it is a new issue that needs a new bug.
You need to log in before you can comment on or make changes to this bug.