accesskey not supported properly

VERIFIED DUPLICATE of bug 959

Status

()

Core
Layout
P3
major
VERIFIED DUPLICATE of bug 959
18 years ago
17 years ago

People

(Reporter: Bernhard Rosenkraenzer, Assigned: joki (gone))

Tracking

({html4})

Trunk
html4
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.3.99-1smp i686)
BuildID:    2000030708

accesskey attributes in html code (included in the HTML 4.0, 4.01 and XHTML 1.0
DTDs) are not supported by mozilla; the keypresses are ignored or mapped to
mozilla functions.
I know this can't be fixed without messing up the user interface we're
accustomed to, so I'm not sure whether or not this should be fixed at all; maybe
make it a configuration option, or ignore the HTML definition and map
Alt+shift+key to accesskey handling?

Reproducible: Always
Steps to Reproduce:
Simple HTML to try:

<html><body>
<u>U</u>ser name:<input type="text" name="username" accesskey="u" />
<U>P</u>assword:<input type="password" name="pass" accesskey="p" />
</body>
</html>


Actual Results:  Alt+u is ignored, Alt+p brings up the printer dialog

Expected Results:  Alt+u should/could have activated the username control,
Alt+p the password control
If this is in the HTML4 spec, we should implement it some way. Changing 
priority, confirming.

Gerv
Severity: enhancement → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: html4

Comment 2

18 years ago
Yup - this is legit, and looks to me like an event handling problem. Joki, 
please take a look.
Assignee: rickg → joki
(Assignee)

Comment 3

18 years ago

*** This bug has been marked as a duplicate of 959 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Indeed, it's a dup.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.