rip out pointless table frame null checks

RESOLVED DUPLICATE of bug 716408

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 716408
12 years ago
6 years ago

People

(Reporter: Bernd, Assigned: Bernd)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
 
(Assignee)

Comment 1

12 years ago
nsTableColGroupFrame::GetContinuousBCBorderWidth should do the same for table frame and col

http://lxr.mozilla.org/seamonkey/source/layout/tables/nsTableColGroupFrame.cpp#548
http://lxr.mozilla.org/seamonkey/source/layout/tables/nsTableColGroupFrame.cpp#549
(Assignee)

Comment 2

12 years ago
Created attachment 224427 [details] [diff] [review]
patch for rowgroups
(Assignee)

Updated

12 years ago
Attachment #224427 - Flags: superreview?(bzbarsky)
Attachment #224427 - Flags: review?(bzbarsky)
So why is this null-check needed?  When does a rowgroup not have a parent table?
Bernd, can you answer the question in comment 3?
(Assignee)

Updated

12 years ago
Attachment #224427 - Flags: superreview?(bzbarsky)
Attachment #224427 - Flags: review?(bzbarsky)
(Assignee)

Comment 5

10 years ago
This is all bogus and comes from my paranoia, we assert inside GetTableFrame, if GetTableFrame does not return a valid table things have gone so far south that a null check will not really help, it will crash anyway rather sooner than later. We could probably rip out some of those pointless null checks.
(Assignee)

Updated

10 years ago
Summary: table frame null check needed → rip out pointless table frame null checks
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 716408
You need to log in before you can comment on or make changes to this bug.