Last Comment Bug 333782 - load doesn't generate xforms-link-error
: load doesn't generate xforms-link-error
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: XForms (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Stephen Pride
Mentors:
Depends on:
Blocks: 326372
  Show dependency treegraph
 
Reported: 2006-04-12 15:49 PDT by aaronr
Modified: 2013-08-05 10:13 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (630 bytes, application/xhtml+xml)
2006-04-12 15:52 PDT, aaronr
no flags Details
testcase 2 (1.04 KB, application/xhtml+xml)
2008-01-25 16:55 PST, aaronr
no flags Details

Description aaronr 2006-04-12 15:49:54 PDT
xf:load with @resource pointing off to a bad link should generate a xforms-link-error and it currently doesn't.  Can use the code out of nsXFormsMessageElement, probably, if we want to just do a simple test of the link first.  Otherwise the code out of label should suffice.  Should also generate an error in the JS console like label does, and generate the error during HandleAction.  Since this is an action, we should probably test the link every time load fires to be consistent with what we are doing in message.
Comment 1 aaronr 2006-04-12 15:52:29 PDT
Created attachment 218223 [details]
testcase
Comment 2 aaronr 2008-01-25 16:55:16 PST
Created attachment 299341 [details]
testcase 2

better testcase
Comment 3 aaronr 2008-01-25 17:03:59 PST
Asked for clarification on whether 4xx or 5xx messages should be displayed or not.  Xforms 1.1 spec sure makes it sound like they shouldn't.

Follow the thread here: http://lists.w3.org/Archives/Public/www-forms/2008Jan/0008.html
Comment 4 Tiziana Sellitto [:tiziana] 2013-08-05 09:45:38 PDT
aaronr this seems to be blocked since 2008. Are you still working on this? Is this still a valid issue?
I'll reset the assignee for now. Feel free to assign it again if I wrong.
Comment 5 Philipp Wagner [:imphil] 2013-08-05 10:12:59 PDT
The Mozilla XForms addon is no longer developed.

Note You need to log in before you can comment on or make changes to this bug.