Closed Bug 333965 Opened 18 years ago Closed 17 years ago

Places' search feature hangs

Categories

(Firefox :: Bookmarks & History, defect, P1)

x86
Windows XP
defect

Tracking

()

VERIFIED FIXED
Firefox 3 beta1

People

(Reporter: ria.klaassen, Assigned: moco)

References

Details

(Keywords: hang, regression)

Steps to reproduce:
1. Open places and type a search term
2. It takes a long time before the whole word appears in the inputfield with cpu usage 100%
3. Firefox hangs for a long time but finally shows the results
4. Now try to wipe out the word pressing Back
5. It takes a long time before the word is gone but there is still a remnant of the search term in the right half of the screen or it does not react at all

I see a similar problem in the popup but there it is even worse; it does not search at all.
Summary: Place's search feature hangs → Places' search feature hangs
Assignee: nobody → bugs
Priority: -- → P2
Target Milestone: --- → Firefox 2 alpha2
It takes 9 seconds now before places shows a search result. That's the same amount of time as it used earlier only to show history.
I just timed a quick search on my machine. It took 2 minutes 40 seconds to search for "test". For that time the firefox windows are unusable.
Wow! When I open places to do a search, and after that I leave places open and then visit Gmail, the CPU gets quite mad. Firefox hangs with every click, comes back for a moment and then hangs again. Until I close places.
Since bug 364325 was fixed this bug shows up worse than ever before.
It is not possible anymore to do a search when you have a large history (about 3 MB).
Once initiated a search, I have to quit for Firefox will not recover within 3 minutes using my default profile (have not tried for a longer time).
And places is even not yet enabled.
Blocks: 364325
with the fix for bug #364325, I removed this optimization:

-  /* don't re-root if the placeURI has not changed */
-  if (gHistoryTree.place == placeURI)
-    return;
-

but it could also be the other part of the patch.

ria / dave, in your history, are you grouped by site, day and site, last visited?
Assignee: bugs → sspitzer
Only By Last Visited. The other views are rather quick, although By Most Visited takes some seconds too (5 sec.).
I don't have as much history data as I did but it does appear that last visited is the slowest to search.
On my Windows XP computer with an AMD Athlon 2000+ processor and 512 MB RAM I
can't use Firefox anymore how it is now, unless I avoid using basic everyday
features like opening the history sidebar "By Last Visited", searching in "By
Last Visited" and surfing with the search window open after a search.

When I open the history sidebar "By Last Visited" the CPU goes immediately to
100%, leaving Firefox unresponsive for at least a full minute. I have no choice
but waiting until it is ready, for trying to stop it by closing the sidebar
makes the hang only worse.

Then, when I'm stupid enough to do a search after that, it will again take over
a minute before I see the first results.

When I forget to close the sidebar and go to GMail, Firefox hangs forever.

I'm talking here about a history from only 60 days.

I copied the same profile files to another computer with an Intel Duo Core
processor and 2048 MB RAM memory, and there I see no problems. The same history
sidebar opens in less than 3 seconds, also the search results display within a
few seconds and opening GMail causes no hang.

These are regressions, caused by Places, that seemingly can't get along with
certain hardware. I have no problem at all with branch builds or pre-Places
builds.
Blocks: 380307
Flags: blocking-firefox3?
Target Milestone: Firefox 2 alpha2 → Firefox 3 alpha5
Priority: P2 → P1
Flags: blocking-firefox3? → blocking-firefox3+
Target Milestone: Firefox 3 alpha5 → Firefox 3 alpha6
ok, lots of good stuff in this bug from Ria and Dave.  One thing I am able to reproduce immediately (with Dave's places.sqlite file) is:

1)  large history, open history sidebar can be very slow, see bug #385245
2)  large history, search for w, very slow (this bug)
3)  large history, after searching for w, with the history sidebar open, visit a page, very slow (this bug)

Working on issue #2 and #3 now.
Status: NEW → ASSIGNED
this needs to be a hard blocker for b1
Target Milestone: Firefox 3 alpha6 → Firefox 3 beta1
Target Milestone: Firefox 3 M7 → Firefox 3 M8
Keywords: hang
Target Milestone: Firefox 3 M8 → Firefox 3 M9
Whiteboard: [needs patch]
bug 401726 was checked in, and i'm not able to reproduce search hangs with that patch applied (and after a shutdown/restart).

could some of you who can reproduce please test this w/ an hourly or tomorrow's nightly?
This WFM or is fixed using Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9a9pre) Gecko/2007110103 Minefield/3.0a9pre ID:2007110103. I had the bug previously. Still hangs a little when finishing typing ...
bug 401722 has been checked in, which should resolve, or at least improve this.
Bug 401726, bug 401722 and bug 381795 were all aimed at this bug. I'm going to close it if no one else can reproduce it.
Whiteboard: [needs patch] → [verification needed]
over 48 hours, no further complaints, closing. please re-open if you're still experiencing this.
Whiteboard: [verification needed]
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
with a history of nearly 15k entries this is working fine
Status: RESOLVED → VERIFIED
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b2pre) Gecko/2007111204 Minefield/3.0b2pre
Searching in history still hangs FF for a very long time
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.