Closed Bug 334264 Opened 14 years ago Closed 13 years ago

text color in about dialog and time picker is not default color

Categories

(Calendar :: Sunbird Only, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: damian.publicemail, Assigned: sipaq)

References

Details

Attachments

(5 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

I switch Windows to some specific theme (see attachment) and open about dialog. Text is not visible, only links at the end of credits

Reproducible: Always

Steps to Reproduce:
1. adjust (Windows OS only) inverse theme
2. open about - dialog
3. switch to credits

Actual Results:  
text is not visible, text color = background color

Expected Results:  
text color should be visible like in about dialog (first "splash")

applicable: Windows OS
version: nightly/2006-04-10-08-trunk/sunbird-0.3a1+.en-US.win32.zip
Version: unspecified → Trunk
Attached image screenshot
Attached file Theme
adjust this theme before tring to reproduce (WinXP, polish)
Whiteboard: [good first bug]
I will take over this bug. Patrick Spendrin
Assignee: base → patrick_spendrin
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → ASSIGNED
Attached image screenshot: minutes
the same effect with minutes-chooser
I attach this defect here, because scenario is the same
I check out rest components and they looks good
Severity: trivial → minor
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Lightning 0.2
Not going to make the 0.3 train.
Component: Internal Components → Sunbird Only
Target Milestone: Lightning 0.3 → Sunbird 0.4
QA Contact: base → sunbird
Not going to make the 0.5 train.
Target Milestone: Sunbird 0.5 → ---
Duplicate of this bug: 375910
Assignee: patrick_spendrin → nobody
Status: ASSIGNED → NEW
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attached patch Patch v1 (obsolete) — Splinter Review
Attachment #260152 - Attachment is obsolete: true
Attachment #260157 - Flags: first-review?(jminta)
Comment on attachment 260157 [details] [diff] [review]
2nd patch - also addresses the problem in the minutes box

       html {
         background-color: white;
+        color: black;
       }
Is this the kind of change that needs to be migrated to other apps too? Or are they already doing it?
(In reply to comment #11)
> Is this the kind of change that needs to be migrated to other apps too? Or are
> they already doing it?

That is the proposed change for Firefox (see bug 374157). It would also be the proposed change for Thunderbird (see bug 375908), but both bugs don't have patches at the moment.
Comment on attachment 260157 [details] [diff] [review]
2nd patch - also addresses the problem in the minutes box

r=jminta.  Bonus points if you fix the other apps. :-)
Attachment #260157 - Flags: first-review?(jminta) → first-review+
Whiteboard: [good first bug] → [good first bug] [checkin needed]
Whiteboard: [good first bug] [checkin needed] → [good first bug] [checkin needed after 0.5]
Fix checked in
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [good first bug] [checkin needed after 0.5]
Target Milestone: --- → 0.7
Verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5pre) Gecko/20070630 Calendar/0.7pre
Status: RESOLVED → VERIFIED
Verified using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5pre) Gecko/20070701 Calendar/0.7pre and a high contrast white on black theme.
Summary: text color in about dialog is not default color → text color in about dialog and time picker is not default color
REOPEN, does not work with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5pre) Gecko/20070707 Calendar/0.7pre
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(In reply to comment #17)
Please specify "does not work". This was verified for Windows with the 20070630 build. What checkin regressed it?
This is how it looks using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.5pre) Gecko/20070708 Calendar/0.7pre. The text is now visible and the Expected Results are fulfilled -> fixed.
for this theme I would expect that background is black and text is white, right now is the opposite but if this was an intenstion, please close it (I see the same as #comment 19)
This is done by intention, because otherwise the dialog would look sucky.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.