[gnome] "No Grouping" "Group By" buttons are same style no matter checked or not

RESOLVED FIXED

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: Ginn Chen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Launch Firefox and go to top menu History->Search in History.
Click "No Grouping" or "Group by Site" toolbar button.
They are same style no matter checked or not.
So user don't know which one is checked.

This bug is not reproducible on Windows.

Comment 1

12 years ago
Created attachment 222458 [details] [diff] [review]
patch

Updated

12 years ago
Attachment #222458 - Flags: review?(mconnor)

Comment 2

12 years ago
Comment on attachment 222458 [details] [diff] [review]
patch

No response from Mconnor in 40+ days.
Attachment #222458 - Flags: review?(mconnor) → review?(bugs.mano)
Comment on attachment 222458 [details] [diff] [review]
patch

I can't test linux-specific changes, so passing this one back to mconnor, sorry.
Attachment #222458 - Flags: review?(bugs.mano) → review?(mconnor)
Mike, see comment 3 please.

Updated

12 years ago
Attachment #222458 - Flags: review?(mconnor) → review+

Comment 5

12 years ago
Checking in toolkit/themes/gnomestripe/global/toolbarbutton.css;
/cvsroot/mozilla/toolkit/themes/gnomestripe/global/toolbarbutton.css,v  <--  toolbarbutton.css
new revision: 1.11; previous revision: 1.10
done
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Note that this is just a poor and ugly workaround, not respecting the GTK theme, causing the buttons to move after each of them is clicked, etc.

For a real fix waiting for months to be checked in, see Bug 254002 (which this one should be marked as duplicate of).

Updated

10 years ago
Duplicate of this bug: 309315
You need to log in before you can comment on or make changes to this bug.