Closed Bug 334598 Opened 14 years ago Closed 3 years ago

Buttons in print preview page are not visible in HighContrastInverse theme.

Categories

(Toolkit :: Printing, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox51 --- fixed

People

(Reporter: tim.miao, Assigned: dao)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

(Keywords: access)

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050607 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.9a1) Gecko/20060416 Firefox/3.0a1

The Previous, First Page, Next and Last Page button are not visible when user set desktop theme to HighContrastInverse theme.

Reproducible: Always

Steps to Reproduce:
1. Change gnome theme settings, select Launch bar->Desktop->Preferences->Theme,
select High ContrastInverse theme, then click Theme Details button. Select
Controls tab and set HighContrastLargePrintInverse, select Icon tab and set
HighContrastInverse. Then close these two setting dialog.
2. Launch firefox and load http://www.sun.com/ .
3. Select top menu File->Print Preview.

Actual Results:  
The Previous, First Page, Next and Last Page button are not visible when user set desktop theme to HighContrastInverse theme.

Expected Results:  
These buttons should be visible and compliant with desktop theme settings.
This bug can be found on vermillion_09/snv_36 with Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.9a1) Gecko/20060416 Firefox/3.0a1.
Keywords: access
OS: Other → Solaris
Hardware: Other → Sun
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirmed on Windows as well.
I added short labels to each button so they appear in high contrast mode.
Assignee: nobody → pilgrim
Status: NEW → ASSIGNED
Attachment #222865 - Flags: review?(mconnor)
Target Milestone: --- → Firefox 2 beta1
Blocks: fox2access
OS: Solaris → All
Hardware: Sun → All
Comment on attachment 222865 [details] [diff] [review]
Add labels to home/previous/next/end buttons

No response from Mconnor in 35+ days.
Attachment #222865 - Flags: review?(mconnor) → review?(bugs.mano)
Flags: blocking-firefox2?
Attachment #222865 - Flags: ui-review?(beltzner) → ui-review+
Comment on attachment 222865 [details] [diff] [review]
Add labels to home/previous/next/end buttons

well, I responded to mark on IRC when the patch was attached, and assumed he'd clear the nomination since this makes the window too big to fit in 800x600
Attachment #222865 - Flags: review?(bugs.mano) → review-
Sorry, I didn't know it was socially acceptable to futz with other people's review flags (even if I was the one who requested it).
(In reply to comment #6)
> Sorry, I didn't know it was socially acceptable to futz with other people's
> review flags (even if I was the one who requested it).

It's okay sometimes if it's obviously the right thing -- like if they accidentally requested it from the wrong person etc.
This'll block the beta2 milestone for now. If we can get it sooner, great!
Flags: blocking-firefox2? → blocking-firefox2+
Target Milestone: Firefox 2 beta1 → Firefox 2 beta2
Well I can't add descriptive labels to the buttons because it makes the toolbar too wide (> 800px).  And the icons seem to disappear in certain themes because they're black.  Can I change the icons to green?  That doesn't really solve the problem in the general case, and it might just spawn additional bugs ("Icons in print preview are not compliant with themes" or some such).

Attaching a patch that uses text to denote the arrows, plus some script that changes their direction based on locale, to match the old CSS chomedir logic.  If this solution is not acceptable, I'm tempted to mark this WONTFIX, since all options seem to be exhausted.
As described in previous comment.
Attachment #222865 - Attachment is obsolete: true
Attachment #228156 - Flags: ui-review?(beltzner)
Attachment #228156 - Flags: review?(bugs.mano)
Comment on attachment 228156 [details] [diff] [review]
patch to use text for navigation arrows

dir="reverse"!?

Anyway, if you need to set labels from a script, use a stringbundleset instead and query the ui-direction using window.getComputedStyle (as in tabbrowser.xml for example).
Attachment #228156 - Flags: review?(bugs.mano) → review-
Blocks: themea11y
No longer blocks: fox2access
Whiteboard: [at risk]
Keywords: sec508
Comment on attachment 228156 [details] [diff] [review]
patch to use text for navigation arrows

I can't say that the current print preview icons are gorgeous enough to not happily replace them with some text label buttons. Until we fix this window elsewhere (it's so horrible, makes everyone cry!) I'm fine with this solution.
Attachment #228156 - Flags: ui-review?(beltzner) → ui-review+
Whiteboard: [at risk] → [needs new patch revision]
Not a regression from 1.5, so we're not going to block. But we'd take that patch if it gets written.
Flags: blocking-firefox2+ → blocking-firefox2-
Target Milestone: Firefox 2 beta2 → Firefox 3
WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a2pre) Gecko/20100217 Minefield/3.7a2pre
Assignee: pilgrim → nobody
Flags: firefox-backlog+
Whiteboard: [needs new patch revision] → [needs new patch revision] p=3
Target Milestone: Firefox 3 → ---
Attached patch patch v2Splinter Review
I didn't localize the labels since these symbols should work universally (just like the image icons).
Assignee: nobody → dao+bmo
Attachment #228156 - Attachment is obsolete: true
Attachment #8778126 - Flags: review?(felipc)
Priority: -- → P3
Whiteboard: [needs new patch revision] p=3
Component: Disability Access → Printing
Product: Firefox → Toolkit
Attachment #8778126 - Flags: review?(felipc) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/fa0934fbb4d5
Use Unicode symbols in print preview page navigation buttons. r=felipe
https://hg.mozilla.org/mozilla-central/rev/fa0934fbb4d5
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Depends on: 1343330
Depends on: 1347126
You need to log in before you can comment on or make changes to this bug.