Open Bug 1016556 (fx-high-contrast) Opened 7 years ago Updated 12 days ago

[meta] Firefox High-Contrast mode bugs

Categories

(Firefox :: Theme, defect, P2)

All
Windows
defect

Tracking

()

REOPENED

People

(Reporter: Dolske, Unassigned)

References

(Depends on 20 open bugs, Blocks 1 open bug)

Details

(Keywords: access, meta)

Windows has a "High-Contrast" mode that's useful for visually-impared users (A11Y). Unfortunately, Firefox often doesn't look very good in this mode. Sometimes we're outright broken -- lower contrast than normal mode! -- in other case we simply don't look visually refined.

Firefox has historically considered A11Y a very important use case, so we should do better in High-Contrast mode.
Flags: firefox-backlog+
Whiteboard: p=0 [qa-]
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Whiteboard: p=0 [qa-] → p=5 s=it-32c-31a-30b.3 [qa-]
Random notes I had jotted down:

Bug 963950 has a couple Australis-specific tidbits, but never really grew into a full-fledged metabug as our ship criteria for Australis was basically just to not make things worse than they already were.

Bug 343205 is a more comprehensive bug, but it's ancient and I don't know how much of it applies any more.

I'd like to see this bug cover a few main thrusts:

* Find and fix obvious visual problems with our theme. Straight-up bugs where contrast is obviously wonky.
* Theme refinement. High-contrast mode should not only have high contrast, but should look _good_.
* Checking in with our A11Y friends to see what else should be considered for inclusion under this umbrella.
And that's everything from my notes.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Depends on: 1252920
Depends on: 1198648
I'm making this a meta bug so we can track this as part of bug 1270272.
Assignee: bmcbride → nobody
Blocks: qx-feedlot
Status: VERIFIED → REOPENED
Component: Firefox Operations → Theme
Keywords: access, meta
Product: Tracking → Firefox
Resolution: FIXED → ---
Summary: Breakdown: Get Windows High-Contrast mode looking good → Get Windows High-Contrast mode looking good
Whiteboard: p=5 s=it-32c-31a-30b.3 [qa-]
Version: --- → Trunk
No longer depends on: 1022595
Depends on: 1051861
Depends on: 1292633
Depends on: 1293023
Depends on: 1293967
No longer depends on: 1252920
Depends on: 1296861
Depends on: 1296945
Depends on: 1298659
Depends on: 1263171
Depends on: 1298685
Depends on: 1298687
Depends on: 1302355
Depends on: 1302405
Depends on: 1303291
Depends on: 1304341
Depends on: 1304973
Depends on: 1301658
Depends on: 1311988
Depends on: 1348198
Depends on: 1348573
Depends on: 1348574
No longer depends on: 1348198
OS: All → Windows
Summary: Get Windows High-Contrast mode looking good → Firefox High-Contrast mode bugs
Alias: fx-high-contrast
Depends on: 1582670
Depends on: 1589391
Summary: Firefox High-Contrast mode bugs → [meta] Firefox High-Contrast mode bugs
Depends on: 1625954
Depends on: 1644242
Priority: -- → P2
Duplicate of this bug: themea11y
Depends on: 1705133
Depends on: 1705776
Depends on: 1706155
Depends on: 1709396
Blocks: hcm

Hi! Going forward bugs here should be tested against a few different HCM configurations -- we have more than just windows support.

  1. Windows HCM (Settings > Ease of Access > High Contrast Mode)
  2. MacOS HCM (System Preferences > Accessibility > Display > Increase Contrast) Note: you may also need to adjust about:preferences (Language & Appearance > Colors > (menulist) Only with High Contrast Themes)
  3. Linux HCM (Accessibility menu > High contrast)
  4. Firefox HCM (Language & Appearance > Colors > (menulist) Always) Note: for this confiugration, you should not have any OS-level contrast preference enabled.
Depends on: 1710082
Depends on: 1710119
Depends on: 1710852
Depends on: 1711258
Depends on: 1711580
Depends on: 1709508
Depends on: 1714766
You need to log in before you can comment on or make changes to this bug.