Linux 1.5 to 1.5.0.2 partials for thunderbird look too large

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: mscott, Unassigned)

Tracking

1.8.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
The linux partial MAR is 5.1 MB.

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/1.5.0.2-candidates/

I opened up the MAR file and most of this size is coming from 

thunderbird-bin

4089150 Apr 19 12:54 thunderbird-bin.patch

Not sure why that's so large yet.
(Reporter)

Comment 1

13 years ago
We thought this could be a regression of Bug #329047. Stefan re-tested the 1.5.0.2 linux candidate build and it looked ok to him though. But that issue may still be the culprit. 
The Linux Thunderbird builds moved build machines between 1.5 and 1.5.0.2, no?

It could be that changes due to moving the environment (glibc, etc.) caused enough changes in the way the binary was laid out that the diff is unreasonably large.

We're not planning on moving machines again, so we may just have to take the hit on Linux for the 1.5.0.2 release; 1.5.0.3's diffs should be smaller again.

Do you remember where 1.5's builds came from (which machine)?
(In reply to comment #2)
> Do you remember where 1.5's builds came from (which machine)?
 
It would have come off the Mozilla1.8 tinderbox, with a BuildID for Tb 1.5 of 20051201.

The tinderbox has respins during the afternoon of the 1st [1]; crazyhorse is the linux tinderbox; build log [2] says 
  "Compiler is -- gcc (gcc (GCC) 3.3.3"

For comparision, the current Tb tinderbox (esx-test-vm1) said (3 days ago, was awol)
  "Compiler is -- gcc (gcc (GCC) 3.3.2 20031022 (Red Hat Linux 3.3.2-1)"
and the Firefox box (moz180-linux-tbox) says now
  "Compiler is -- gcc (gcc (GCC) 3.3.2 20031022 (Red Hat Linux 3.3.2-1)"

[1] http://tinderbox.mozilla.org/showbuilds.cgi?tree=Mozilla1.8&maxdate=1133481600&legend=0
[2] http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla1.8/1133471880.5984.gz&fulltext=1
(In reply to comment #3)

> It would have come off the Mozilla1.8 tinderbox, with a BuildID for Tb 1.5 of
> 20051201.

Hrm... 3.3.2 vs. 3.3.3... I'm actually more curious what the linker versions were (since that's probably more likely to affect layout):

[cltbld@crazyhorse cltbld]$ ld -v
GNU ld version 2.13.90.0.2 20020802

[cltbld@esx-test-vm1 cltbld]$ ld -v
GNU ld version 2.14.90.0.4 20030523

Great.

Well, the real question is: if the updates work *and* we haven't broken binary compatibility in [a noticeable] way, are we going to respin/re-release all Linux bits?

This is somewhat problematic since, the blogosphere seems to think we've already released... so a respin would be multiple levels of badness.
(Reporter)

Comment 5

13 years ago
I'm trying to think about what other ramifications we might have by releasing 1.5.0.2 with a different linker for 1.5. I think we need to reach a wider audience on getting input on this this morning. 

I'm not too worried about folks who already saw the builds on stage if we do respin. It looks like only 3,000 people found the builds on the ftp directory last night and downloaded it. And linux would be a  small percentage of that. For that handful of users, the next time they get updated to 1.5.0.3, would the partial fail, and would they get moved to a full update (which would be ok), or would they get stranded with this bad build.
(Reporter)

Comment 6

13 years ago
Another thing to think about. what happens when 1.5.0.x users get updated to Thunderbird 2 (which comes off crazyhorse)? I guess they'd get another large partial patch to get them back to a build linked with 2.13.90.0.2. 
won't 1.5 -> 2 be large no matter what linker is used?

Comment 8

13 years ago
Aren't linux users the most likely to have a high speed connection and not care so much about large partials? The issue that concerns me more is the potential binary incompatibility with extensions. Does enigmail work?
(In reply to comment #6)
> Another thing to think about. what happens when 1.5.0.x users get updated to
> Thunderbird 2 (which comes off crazyhorse)? I guess they'd get another large
> partial patch to get them back to a build linked with 2.13.90.0.2. 
> 

I thought it had pretty much been decided that we weren't going to offer the 1.5 -> 2.0 update via the update service... We didn't offer 1.0 -> 1.5, and there was a huge debate about it.
(Reporter)

Comment 10

13 years ago
Paul, I just downloaded 1.5 on linux and loaded up about:buildconfig in the default start page window. And I can confirm that it was built using gcc 3.3.3. I think this gives us a little more confidence that the build environment on crazyhorse hasn't changed since we shipped 1.5 (at least from a gcc point of view). 
(Reporter)

Comment 11

13 years ago
For those following at home, the linux en-US build is now available:

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/1.5.0.2-candidates/thunderbird-1.5.0.2.en-US.linux-i686.tar.gz

preed rocks.
l10n bits are  now available in that directory too.

Also, encouraging news: I'm starting to generate partial updates. The bg locale partial update is 696k.
Hardly relevant anymore, closing as WFM.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.