Attempting to Update Thunderbird as a Limited User Causes Restart Loop

RESOLVED INVALID

Status

Thunderbird
Installer
--
enhancement
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Matthew Murphy, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

I routinely run as a Limited User.  I have two accounts on my PC, one of which is an administrator.  I do not use this second account for any internet-exposed application, only when necessary to make system changes.

The unfortunate consequence of this is that one sometimes forgets that he/she is running with limited privileges and tells Thunderbird to install a new update.  I did this with 1.5.0.2, and the results were rather startling.

Much to my surprise, Thunderbird actually said it was prepared to restart and apply the update.  By this point, the "DOH!  I'm a limited user!" reaction had already taken place.  So, Thunderbird restarted.  And of course the update failed.  And it restarted again.  Much to my horror, it once again attempted to apply the update, failing again.  The cycle continued for a few minutes, at which point I used Task Manager to terminate Thunderbird and the updater.

I then ran Thunderbird as an administrative user and the update completed.  I closed the instance of Thunderbird that started in my administrative context.  Restarting it as a user worked normally.

Reproducible: Always

Steps to Reproduce:
1. Install a version of Thunderbird that is not current (prior to 1.5.0.2).
2. Log in as a limited user.
3. Start Thunderbird.
4. Choose the "Check for Updates" option from the Help menu.

Actual Results:  
Thunderbird attempts to install the update, fails and attempts once again when it is restarted.

Expected Results:  
Thunderbird should indeed fail to apply the update, but once an update is not successfully applied, the restart should cause the product to load without the update applied and thus function without it.

I see two issues here.  First of all is that Thunderbird should not loop when an update fails to apply.  That's a serious issue in and of itself.

The second thing is that it would be nice for the update feature to at least warn a limited user about the inability to install software updates.  Ideally, the updater should prompt for an administrative user's password if the update is unable to install for lack of privilege on the system.
(Reporter)

Comment 1

12 years ago
Sorry folks... works on .0.2.  Seems to be a case of "user not testing sufficiently."
Severity: major → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.