Closed Bug 335346 Opened 15 years ago Closed 12 years ago

Firefox CRASH 100% of time when attempting to compose a Yahoo email.

Categories

(Core :: Layout, defect)

1.8 Branch
x86
Windows 2000
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX

People

(Reporter: pcbonez, Unassigned)

Details

(Keywords: crash)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

I click on "Compose" and Firefox immediatly crashes.
-ALL- open Firefox Windows disappear.
A window pops up that says Firefox has to be restarted.
Feedback agent pops up and says it's logging the crash and it seems to save it but the Feedback agent won't send from my PC anyway. (Another issue.)
.

Reproducible: Always

Steps to Reproduce:
1.Log into Yahoo
2.Click on Compose
3.Watch Firefox CRASH
4.Happens 100% of the time.

Actual Results:  
Firefox CRASH

Expected Results:  
Should have opened a blank email in edit mode.

Firefox is at all defaults as far as I know.
.
The Feedback Agent never works on my system. (EVER for ANY crash.)
.
The same thing happens most of the time when I try to Forward mail.
.
Gateway Solo 9150 Laptop . 440 BX Chipset . P2-400 . 256-MB RAM .
.
I dunno how to "note a module". Wassa Module??
.
.
about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-official-branding --enable-svg --enable-canvas --enable-update-packaging 
.
No crash with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Can you reproduce this in Firefox's safe-mode or with a new profile?
http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder
If it still happens, could you provide a talkback ID?
http://kb.mozillazine.org/Talkback
Just tried myself. No crash.
This has been ongoing every since I updated to Firefox 1.5.0.2.
I don't remember which older version I had but it did not do this at all.
Happens everytime I try to compose an email.
I don't 'forward' much but it happens often. Maybe always.
I can only read Yahoo mail with Firefox. 
For anything else in Yahoo mail I have to use IE because about everything else crashes Firefox most of the time. Compose seems to do it every time.
.

I muddled through the helps and got Feedback Agent and Talkback to work.
Unfortunatly the que got so full I deleted them recently.
Current IDs: TB17941717Q and TB17977887K and TB17978059Y
.
Will try safemode next.
.
I didn't know there WERE other profiles. 
I'll try to figure that comment out and do it.
.
I know hardware but I know squat about programming.
Thanks for the help so far!!!
.
Seems to work fine in a new blank profile.
.
I still haven't found how to get into safe mode.
~ Looking.
.
Seems to work fine in Safe Mode.
.
Would be nice if how to get to Safe Mode was in the help files instead of burried in the site.
.
What do I do now?
.
I udated "Adblock" and it still happens but not every time. 

TB18014909Y
.
TB18020008G
Those are all different crashes.
Keywords: crash
Version: unspecified → 1.5.0.x Branch
~ They are ALL Yahoo related. ~
Does not happen outside of Yahoo. 
Something is in common. ~ What?

As said, I am not a programmer. Is all gibberish to me.

Firefox simply not compatible with Yahoo??

FeedBack agent crashed and lost the record of several crashes before I Talk Backed them here.

TB18236083M
.
Fresh 1.5.0.3 does it too.

TB18237000X
Fresh 1.5.0.3 does it too.

TB18237000X
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: 1.5.0.x Branch → 1.8 Branch

*** This bug has been marked as a duplicate of 326344 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 326344 ***

Yeah,, That's nice except:
I'm not using XP.
I don't have the npYState.dll plugin.
~ The file is non-existant on my system.

TB18361757E
TB18361767Z
TB18391120Q
.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
one of your previous 3 stacks had a plugin reference in it, the resolution wasn't so bad based on it.

of your current 3 stacks, only one has a usable stack trace:
	
Incident ID: 18361767
Stack Signature	ntdll.dll + 0x4c2c0 (0x77fcc2c0) 9c73ab7b
Product ID	Firefox15
Build ID	2006042618
Trigger Time	2006-05-05 11:06:47.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	ntdll.dll + (0004c2c0)
URL visited	
User Comments	Yahoo Mail - clicked 'send'
Since Last Crash	1076 sec
Total Uptime	29770 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
ntdll.dll + 0x4c2c0 (0x77fcc2c0)
MSVCRT.DLL + 0x1532 (0x78001532)
MSVCRT.DLL + 0x14cf (0x780014cf)
XPCWrappedNative::CallMethod  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 1997]
XPC_WN_CallMethod  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1444]
js_Invoke  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1177]
js_Interpret  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 3562]
js_Invoke  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1197]
js_InternalInvoke  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1274]
js_InternalGetOrSet  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1333]
js_GetProperty  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsobj.c, line 2985]
js_Interpret  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 5291]
js_Invoke  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1197]
js_InternalInvoke  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1274]
js_InternalGetOrSet  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1333]
js_SetProperty  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsobj.c, line 3071]
js_Interpret  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 3397]
js_Invoke  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1197]
nsXPCWrappedJSClass::CallMethod  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1372]
nsXPCWrappedJS::CallMethod  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 462]
SharedStub  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp, line 147]
nsBrowserStatusFilter::ProcessTimeout  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/xpfe/browser/src/nsBrowserStatusFilter.cpp, line 300]
nsAppStartup::Run  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 151]
main  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/browser/app/nsBrowserApp.cpp, line 61]
KERNEL32.DLL + 0x2893d (0x7c59893d)

And it just indicates heap corruption. we can't do much w/ that. If you're willing to run a custom build under a debugger, perhaps this can be chased.
TB18391993Q
That DLL file isn't even on my computer so if you saw it somewhere I dunno where it's coming from.

I'm Certifed on Experts Exchange for Hardware, Desktops, and Laptops.. 
I'm not a programmer though and if I knew what a usuable stack trace was I'd only send those.. LOL

I like to learn.... 
I'm willing to try whatever but I might need baby sat to get through it.
.
http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg is the starting point. poke back once you've played with the basics.

unfortunately the simplest basic past that is getting a purify trial license, but that shouldn't actually be out of the realm of possibility. feel free to contact a couple of people on irc.mozilla.org about how to use purify before you start the license clock since we want you using it, not learning how to use it. i suppose you could probably start near http://www.google.com/search?hl=en&lr=&q=purify+site%3Amozilla.org&btnG=Search for info about purify.
Well, the stack traces and problem description are very typical for bug 326344 - so you still might want to check about:plugins.
PCBONEZ, do you continue to experience this with the latest nightlies?  we've not been able to reproduce your crash.
I'm re-doing my office and PC's. 
I'll play with it when I get my work space put back together.
Thanks for the help so far people!!!
Still doing it.
It's consistant and only whne using yahoo mail.
I'm lucky to get through 2 emails before Firefox crashes.

TB19158781Q
TB19158568W
TB19158376M
TB19157904M
TB18882975Y

.

bug reporter,

if you have yahoo messenger installed, try the new version 8.1 http://messenger.yahoo.com/ which is reported in bug 322363.

If your problem goes away then close your bug as a duplicate of bug 322363.
~~~~~~~~
I don't use yahoo messenger.
The problem occures using yahoo email even when that's the only thing open.
It's consistant. Yahoo email ALWAYS crashes Firefox on that machine.
~~~~~~~~
Crashes for me to if I click on Compose on the Yahoo Toolbar.
file a new bug (this bug had been dead for over a year before you tried to resurrect it), and include your version info, talkback incident ids/breakpad ids (about:crashes), your list of plugins (about:plugins) and which messengers you have installed.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago12 years ago
Resolution: --- → INCOMPLETE
Bug went dead because no one bother to work on it.
Never went away. NEVER FIXED.
After 2 years of no significant interest or assistance from "The Team" I don't care anymore.
Resolution: INCOMPLETE → WONTFIX
You need to log in before you can comment on or make changes to this bug.