Yahoo Application State plugin seems to cause random Firefox 1.5 crashes

RESOLVED FIXED

Status

defect
RESOLVED FIXED
14 years ago
4 years ago

People

(Reporter: vlad, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Installing the Yahoo IM client also installed the "Yahoo Application State" (pYState.dll) plugin, which -seemed- to cause all sorts of strange stack-scribbling crashes.  I don't have proof of cause, other than that once I forcefully uninstalled the plugin (by renaming the dll in Yahoo IM's folder), I have yet to crash once.

We're seeing a lot of strange 1.5 crashes; it would be useful to see if people who are seeing these crashes have the App State plugin installed

Talkbacks are not helpful:

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=13478910
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=13478639
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=13423537
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=13364197
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=13343198
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=13247382

etc.

I'm going to do a full debug build and turn it back on, and see if I can get some more useful information.
*** Bug 322480 has been marked as a duplicate of this bug. ***
(In reply to comment #1)
> *** Bug 322480 has been marked as a duplicate of this bug. ***
> 

I get these crashes when logging into Yahoo! Mail beta. Reproduceable everytime.
My stacktraces are completly different though. 

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB13602932Z
Kurt: if you disable the Yahoo plugin, by renaming pYState.dll temporarily, do the crashes go away?

Do we know anyone at Yahoo who can look at this with us?
(In reply to comment #3)
> Kurt: if you disable the Yahoo plugin, by renaming pYState.dll temporarily, do
> the crashes go away?

I dont have this dll nor do I have yahoo IM installed since it's banned where I work.

Not this bug then, I'll reopen yours.
FWIW, the default location for that plugin is C:\Program Files\Yahoo!\Shared\npYState.dll
Nate: any chance you can help us out here?
Depends on: 316507
Depends on: 326344
No longer depends on: 316507
I have recently just run into this error also. Some additional info that you may or may not have is:

1. I confrimed that the issues go away by renaming the npYState.dll file to npYState.dll_ (# 3 below is not replicatable after >35 attempts)

2. It does not happen if you open firefox using it's "safe mode" link through the start menu. (# 3 below is not replicatable after >10 attempts)

3. It happens more frequently (not repeatably, but can be generated in 2 - 3 minutes) if you open multiple (>3) windows and close one then right click on a link in the remaining screen. At most I've had to go through 10 windows with at least 2 remaining open to replicate the problem. Note: all windows must be Yahoo mail windows. 

4. My system is Windows 2000 build 5.00.2195 (SP 4) running an AMD 64 bit processor. About Firefox states: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6. Which was just updated before the testing outlined above.

Thanks for listening.
*** Bug 351051 has been marked as a duplicate of this bug. ***
*** Bug 351172 has been marked as a duplicate of this bug. ***
I installed Messenger 8.0 and am now have several ways to reproduce this crash in my default profile.  I'll ping the Messenger team about it.
according to the Messenger team this is fixed in the next Messenger release.
*** Bug 360128 has been marked as a duplicate of this bug. ***
I updated to version 8.1 of Yahoo messenger and I no longer see any crashes when using yahoo mail.  I used to see this pretty regularly with version 7.5.
*** Bug 357141 has been marked as a duplicate of this bug. ***
*** Bug 355519 has been marked as a duplicate of this bug. ***
I tried npYState.dll from Yahoo Messenger 8.1 and I couldn't reproduce the crashes with the testcase in bug 326344, neither could I make Firefox crash on Yahoo Mail. Should this be resolved as fixed?
*** Bug 362145 has been marked as a duplicate of this bug. ***
Doesn't seem to be resolved.  I downloaded messenger just yesterday from Yahoo and  my whole FF will crash, just blink off really, when I am working in Yahoo mail.
I just had it happen to me when I hit the "new posts" button on this forum.

http://www.speforums.com/forum.php
Do you have any talkbacks?  I don't see how the yahoo state plugin could be involved with a non-yahoo site.  
I haven't received anything back yet.  I don't understand either haw this could be  effecting other forums but I figured I better send it in because maybe their might be some common cause.
Wladimir in comment #17:
> Should this be resolved as fixed?

Vlad, fixed?
I haven't seen any reports of this issue in a few months. I guess Yahoo Messenger updates itself automatically.
Updated Yahoo Messenger to 8.1 and crashes returned; renamed npYState.dll and crashes stopped so this bug may still exist.
Assignee: vladimir → nobody
This one is still definitely alive.
I also got one report that this bug might have returned.
Just upgraded to the newest version of Y IM 8.1.0421 and thought it made things better, then this morning exact same crash coming out of Pidgin alerts into Yahoo email.  Haven't tried moving the .dll yet.
messenger 9 beta any better?
Duplicate of this bug: 347179
Duplicate of this bug: 346173
Blocks: abp
This has not been an issue for a while and the Yahoo plugin was blocklisted http://www.mozilla.com/en-US/blocklist/ - Fixed?
Duplicate of this bug: 505349
marking fixed because this plugin is blocklisted
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.