Account Manager freezes when creating new account

VERIFIED DUPLICATE of bug 34484

Status

SeaMonkey
MailNews: Account Configuration
P3
blocker
VERIFIED DUPLICATE of bug 34484
18 years ago
13 years ago

People

(Reporter: cls, Assigned: Dan M)

Tracking

({pp})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
More accurately, the Incoming Server dialog refuses to accept any input once you
change the Server Type: drop down menu from the default.

When I Ctrl-C'd out of a gdb session, I wind up with 5 threads running:
(gdb) info threads
  6 Thread 8626  0x4054fa40 in __poll (fds=0xbf1ffae8, nfds=1, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:45
* 4 Thread 8618  0x404c2d1b in __sigsuspend (set=0xbf5ffb3c)
    at ../sysdeps/unix/sysv/linux/sigsuspend.c:48
  3 Thread 8617  0x4054fa40 in __poll (fds=0xbf7ffc88, nfds=2, timeout=35000)
    at ../sysdeps/unix/sysv/linux/poll.c:45
  2 Thread 8614 (initial thread)  0x4054fa40 in __poll (fds=0x8f76d10, nfds=4, 
    timeout=500) at ../sysdeps/unix/sysv/linux/poll.c:45
  1 Thread 8616 (manager thread)  0x4054fa40 in __poll (fds=0x819e940, nfds=1, 
    timeout=2000) at ../sysdeps/unix/sysv/linux/poll.c:45

(gdb) bt
#0  0x404c2d1b in __sigsuspend (set=0xbf5ffb3c)
    at ../sysdeps/unix/sysv/linux/sigsuspend.c:48
#1  0x40257c22 in __pthread_wait_for_restart_signal (self=0xbf5ffe40)
    at pthread.c:785
#2  0x40254960 in pthread_cond_wait (cond=0x81a4d14, mutex=0x81a005c)
    at restart.h:26
#3  0x40233ed0 in PR_WaitCondVar (cvar=0x81a4d10, timeout=4294967295)
    at ../../../../../mozilla/nsprpub/pr/src/pthreads/ptsynch.c:360
#4  0x40234771 in PR_Wait (mon=0x81a0058, timeout=4294967295)
    at ../../../../../mozilla/nsprpub/pr/src/pthreads/ptsynch.c:545
#5  0x4018dad1 in nsThreadPool::GetRequest (this=0x81a1148)
    at ../../../mozilla/xpcom/threads/nsThread.cpp:409
#6  0x4018e80c in nsThreadPoolRunnable::Run (this=0x81b45a8)
    at ../../../mozilla/xpcom/threads/nsThread.cpp:604
#7  0x4018c86d in nsThread::Main (arg=0x81ded78)
    at ../../../mozilla/xpcom/threads/nsThread.cpp:83
#8  0x4023b6e1 in _pt_root (arg=0x81b44b0)
    at ../../../../../mozilla/nsprpub/pr/src/pthreads/ptthread.c:157
#9  0x40255b25 in pthread_start_thread (arg=0xbf5ffe40) at manager.c:241
(gdb)

Updated

18 years ago
Assignee: alecf → danm

Comment 1

18 years ago
this is a modal-on-a-modal problem. reassign to danm, cc blizzard.



cls: in the mean time you can do File->New->Account

Updated

18 years ago
Keywords: beta2
QA Contact: lchiang → nbaca

Comment 2

18 years ago
Build 2000-03-27-08M14: Linux 6.0
Reproduced the problem.

Steps to reproduce:
1. Create a new profile
2. Create the first account using IMAP. In the Account Wizard's Server dialog I 
was able to select IMAP for the Server Type and enter a Server Name.
3. Create a second IMAP account. On the Server dialog change the Server Type to 
IMAP and try to enter a Server Name.

Actual Results: Tried clicking into the Server Name field and the cursor never 
appears so it's impossible to enter a Server Name.

Expected Results: The cursor should appear in the Server Name text box. After 
typing, text should also appear.

Additional Information:
- NT4, build 2000-03-27-09M15: Ok, does not exhibit the problem.
- Mac 8.5.1, build 2000-27-09M14: Ok, does not exhibit the problem.
Keywords: pp

Comment 3

18 years ago
setting from blank to M15 milestone for these bugs affecting mail/news.  If you 
disagree, pls comment and add selmer@netscape.com to cc: list.
Target Milestone: --- → M15
(Assignee)

Updated

18 years ago
Target Milestone: M15 → M16
(Assignee)

Comment 4

18 years ago
Same as (later, but more general) bug 34484.


*** This bug has been marked as a duplicate of 34484 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED

Updated

18 years ago
Keywords: nsbeta2
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.