richlistbox - ability to select an item without focus when content is built

RESOLVED DUPLICATE of bug 298371

Status

()

defect
RESOLVED DUPLICATE of bug 298371
13 years ago
12 years ago

People

(Reporter: rstrong, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

The Extension Manager is now able to create views into the extensions datasource via what are essentially pref panel buttons - see Bug 329045. The current richlistbox code selects and focuses the last selected richlistitem on build which is inappropriate when using the keyboard to navigate.

Another change is that the content of the richlistitem changes on select which changes the element height which causes problems with ensureElementIsVisible.

I put an override in extensions.xml to handle this case for the Extension Manager but it would be a good thing for these items to be implemented in richlistbox or richlistitem itself.
I also needed a way to determine if the richlistbox is focused for styling purposes.
That override doesn't work anymore due to the overriden method having been removed in bug 298371. AFAICT it's no longer necessary, either, and should thus be removed.

As for comment #1: when the richlistbox itself has the focus, richlistbox:focus should work. That rule (correctly) doesn't apply when a focusable element inside a richlistitem is focused though.
Resolving duplicate of bug 298371 since that added the functionality requested.
Filed Bug 387392 to remove the overrides.
Thanks!
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 298371
You need to log in before you can comment on or make changes to this bug.