[wish] Messages of a folder saved in individual files (instead of one big file)

RESOLVED DUPLICATE of bug 58308

Status

enhancement
RESOLVED DUPLICATE of bug 58308
13 years ago
9 years ago

People

(Reporter: Philippe.Poilbarbe, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Thunderbird 1.5.0.2

Saving the mail messages in individual files instead of one big file would be a great enhancement; not necessarly for a point of vue since it would not change anything to the visual interface (except that the 'compress folder' function would disapear).
+ The whole 1Gb file would not have to be saved only because a 1Kb message have be read (the main goal for this feature).
+ Deleting a message is only renaming a file into the trash folder
+ Deleting a folder is only renaming a directory into the trash folder
+ No folder compression needed
+ No limit on file size (each message is only limited by maximum file size of the filesystem, and not the whole folder)
+ Filesystem directory tree would reflect the folder tree (one directory for a folder, one file for a message).
+ Retreiving a unix-like mail file (like used now) is only concatenating all the message files of a folder
- Breaking format habit
- Indexing may be longer (but I am not sure)
- File name management needed when moving/creating/importing messages
- Long folders (with many messages) may reach filesystem limitation (to much files in one directory)
- No undelete possibility when the trash has been freed


Reproducible: Always

Comment 1

13 years ago
> The whole 1Gb file would not have to be saved only because a 1Kb message have
> be read (the main goal for this feature).

That doesn't happen today, so I'm not sure what you're talking about. To mark a message read, we just rewrite one character in the file.

the big advantages of maildir support are:

1. no need for compaction
2. editing a message would only involve rewriting the message, not the whole mailbox.
3. virus checkers won't delete your whole inbox

the disadvantages are:

1. Increased disk space usage
2. Message body searches will slow down enormously because we don't index message body contents, and searching will involve opening every file/msg.
Whiteboard: dupeme
Duping to the bug about maildir support.

*** This bug has been marked as a duplicate of 58308 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.