Provide both "basic" and "full" XForms extension

RESOLVED WONTFIX

Status

Core Graveyard
XForms
--
enhancement
RESOLVED WONTFIX
12 years ago
2 years ago

People

(Reporter: Steve Speicher, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

Now that XForms extension has complex schema support it now exceeds the criteria for "basic" profile support.

There should be a mechanism, say by mozconfig, to enable different levels of xforms.  For example when,
  ac_add_options --enable-extensions="default,minimo,xforms"
this would build Minimo + XForms basic (without complex type schema validation) and with property conformance-level="basic"
See http://www.w3.org/TR/xforms/slice12.html#conform-levels-full

or something like this, just an example.  Important thing is to be able to keep the mobile footprint as small as possible.

This is related to bug 334333

Reproducible: Always

Comment 1

12 years ago
I can see that it would be nice to make the schema-validation stuff smaller and more efficient for minimo or embedded devices, possibly.

Doron, can this be achieved without significant penalty or complexity to the XForms code?  Without significant complexity to the schema-validation code?  What kind of size savings could we expect?

Comment 2

12 years ago
(In reply to comment #1)
> I can see that it would be nice to make the schema-validation stuff smaller and
> more efficient for minimo or embedded devices, possibly.
> 
> Doron, can this be achieved without significant penalty or complexity to the
> XForms code?  Without significant complexity to the schema-validation code? 
> What kind of size savings could we expect?
> 

Complex schema support could be easily encapsulated inside ifdefs, since all that code is in seperate methods.  Then inside Validate() you could ifdef out the ValidateComplexType call and add a NS_ERROR_NOT_SUPPORTED return (basically the old code before complex type was added).

The XForms makefile could set a SCHEMA_DISABLE_COMPLEX_SUPPORT definition which schema validation would follow.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

12 years ago
Assignee: aaronr → xforms
RIP xforms
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.