Advanced Automatic Email Filtering

RESOLVED DUPLICATE of bug 181866

Status

--
enhancement
RESOLVED DUPLICATE of bug 181866
13 years ago
10 years ago

People

(Reporter: bcwhite, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050927 Debian/1.7.8-1sarge3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050927 Debian/1.7.8-1sarge3

I had a conversation with a couple of my users yesterday regarding email filtering.  One was technically competent and one was just a basic user, but both had the same trouble...  Too much email.

Simple filtering was either too complex to explain or too much work to get right, so what follows is an idea I came up with.  I figure this has come up before, but didn't find it in a quick Google search so thought I'd post about it...


What I and my users think would work well would be a learning classifier, possibly based on the CRM114 code, that would learn every time a message was moved around.  The reason I suggest CRM instead of simpler word-based categorization ("a plan for spam") is that the CRM114 author claims excellent results when classifying to multiple categories.

Every time a folder is created, there would be a checkbox (selected by default) like "automatically filter to this mailbox".  Then, every time a message were moved to that box, the system would learn from it.  Every time a message were moved out (except to Trash), it would unlearn it (a false-positive).

With this kind of simple and automatic feedback from the user, the system should quickly become very good at the classification.  Filtering spam becomes just one case of the classifer.


What do people think of this kind of user interface?


Reproducible: Always

Comment 1

13 years ago
dupe of bug 151622 and/or bug 229686. See also bug 181866.
(Reporter)

Comment 2

13 years ago
I don't think it's a dupe of bug 151622 and/or bug 229686 since those are about spam and this isn't.

However, it's very similar to bug 181866.
QA Contact: front-end

Updated

10 years ago
Assignee: mscott → nobody
(In reply to comment #2)
[...]
> However, it's very similar to bug 181866.

...which has the additional advantage of having seen some fixing attempts even this year.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 181866
You need to log in before you can comment on or make changes to this bug.