Imported bookmarks with Chinese characters from IE have ???? in place of Chinese characters

RESOLVED DUPLICATE of bug 174734

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 174734
12 years ago
4 years ago

People

(Reporter: D C, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

Confirmed on two separate systems.  Once Firefox is installed and it "auto-imports" bookmarks from IE, any Chinese characters in the imported bookmarks show up as "???" under Bookmarks.

Reproducible: Always

Steps to Reproduce:
1.Install Firefox
2.Import bookmarks from IE that have Chinese characters
3.Check Firefox bookmarks to see "???" in place of Chinese characters

Actual Results:  
Firefox bookmarks to see "???" in place of Chinese characters.

Expected Results:  
Firefox should properly display Chinese characters in bookmarks to homepages with titles containing Chinese characters.
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5.0.x Branch

Updated

12 years ago
Whiteboard: DUPEME

Comment 1

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060912 Minefield/3.0a1
Windows XP SP2

Didn't get auto-import prompt, but File/Import WFM

Comment 2

11 years ago
Importing Chinese bookmarks on Chinese Windows works fine. This bug only manifests itself when the default codepage cannot cover characters used in bookmark file names. 

It won't be fixed on FF 1.5.0.x (gecko 1.5.0.x), but it's already fixed for upcoming FF 2.0 (gecko 1.8.x)


*** This bug has been marked as a duplicate of 174734 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.