Closed Bug 174734 Opened 18 years ago Closed 14 years ago

IE bookmarks with names made of characters not covered by the system default codepage do not show up in bookmarks (e.g. Russian/Japanese/Chinese on English/French Windows)

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: aherana, Assigned: jshin1987)

References

Details

(Keywords: fixed1.8.1, intl)

Imported IE6 bookmarks which start with a non-English character are not 
displayed in the Phoenix bookmarks. Note that this is referring to the "name" 
of the bookmark, and not the URL. Experienced this with Japanese and Ukrainian 
links.
Please query for existing bug reports before filing new ones. Filing duplicate
bug reports wastes a lot of developer and QA time. Thanks. 

*** This bug has been marked as a duplicate of 111428 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Mass verifiying of old duplicates.
Status: RESOLVED → VERIFIED
Reopening - bug 111428 is for Seamonkey, and this code is, I think, forked.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
Assignee: p_ch → vladimir+bm
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: asa → mconnor
Keywords: intl
Flags: blocking-aviary1.1?
jshin, is this fixable in the current timeframe for 1.8b3/4, or should we let it
slide until we have a real alpha cycle to test in?
Importing Russian bookmarks (IE favorites) on English Windows (and many similar
cases) depends on bug 162361. I really wanted to fix that bug before 1.1 ships,
but it's been tough to find the time to work on that. I'll try my best. 
In the meantime, I made some fixes in the IE import code which will ensure this
bug will be fixed right after bug 162361 is fixed.
Depends on: 162361
Where alienating are foreign users here. I bug like this can't POSSIBLY make it
into 1.1.
bug verified on trunk using german windows xp sr-2:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050623
Firefox/1.0+ ID:2005062314

bookmarks named with german umlauts (ÄÜÖ) at the beginning do not show up in the
menu - they are searchable & visible in the manager though.
> bug verified on trunk using german windows xp sr-2:

> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050623
> Firefox/1.0+ ID:2005062314

> bookmarks named with german umlauts (ÄÜÖ) at the beginning do not show up in the
> menu 

What's your setting for 'non-Unicode programs'? If it's German (French, English,
Swedish, etc), you shouldn't have any problem with German umlauts. This bug is
not about any ASCII characters but about characters that are not covered by the
file system encoding (Cyrillic letters on English Winodws, Chinese characters on
Russian Windows, etc).
Summary: Links starting with non-English characters in name do not show up in bookmarks → IE bookmarks with names made of characters not covered by the system default codepage do not show up in bookmarks (e.g. Russian/Japanese/Chinese on English/French Windows)
(In reply to comment #8)

> What's your setting for 'non-Unicode programs'? 

   in Control Panel - Regional Settings(?) 

> This bug is
> not about any ASCII characters but about characters that are not covered by 

==> not about any non-ASCII characters but about ...
(In reply to comment #9)

sorry, then i missunderstood the bug description. the old one fit to my problem,
the new one changed by you not. indeed i'm on a german windows using an english
firefox, so firefox should have no problem with showing umlauts (what _are_
definately non-english characters) in bookmarks (at the beginning of an entry) -
but, is it then now a whole different bug (which) ?
I can't reproduce your problem (if we had that bug, it would be a lot more
serious bug than this one and I would try hard to fix it ASAP), which is why I
asked you what value you have in Control Panel - Regional (?) Options -
'Codepage to use for non-Unicode programs' . The UI language of Windows XP/2k
(in your case German) IS indepdent of the 'ANSI' codepage to use for non-Unicode
programs so that it can be Windows-1251 (for Russian) wheras the UI language of
your Windows XP is German. 
please ignore my comments regarding this bug. german umlauts actually are
_shown_  in the bookmarks. sorry for this :-/
The only person who's probably going to be able to fix this is jshin, and it
doesn't look like 162361 will make it at present.

I thought I saw a related bug land and get backed out, I may be wrong, but I
can't find it.
Assignee: vladimir+bm → jshin1987
Flags: blocking-aviary1.1? → blocking-aviary1.1-
Fair enough to remove this from the blocker list, but I've begun to work on bug
162361 again a couple of days ago and am hoping to make some progress soon.

I am trying to export IE Favorites from Windows XP SP2/IE 6.0 to SUSE 
9.3/Firefox 1.0.5. Any non-ASCII characters are not imported properly in 
bookmark names. For example I have a bookmark with name "Säästöpankki". It is 
imported as "S��st�pankki" (� = question mark inside a black circle). 
 
I believe this to be due to the fact that IE Favorites export file is encoded 
as ISO-8859-1 and Firefox imports it as UTF-8, and only ASCII characters are 
conversed. Note that the error happens on Linux platform. 
 
Is this the same bug or not? 
 
re comment #15:
Your problem is a completely separate problem. More importantly, it's MS IE's
bug not firefox'. Why it uses the character encoding of the default ANSI locale
instead of UTF-8/UTF-16 when exporting favorites to bookmark.htm is beyond me.
Why don't you just manually add

<meta http-equiv="Content-Type" content="charset=Windows-1252">

to 'bookmark.htm' *generated by MS IE*.  Alternative, why don't you convert it
to UTF-8 using 'iconv -f CP1252 -t UTF-8 bookmark.html bookmark.new.htm' ? 
re comments #15 & #16.

Adding charset=iso-8859-1 for example to bookmark.htm doesn't help, Firefox 
ignores it and imports it in any case as UTF-8.

iconv probably works, but that requires special Linux knowledge, and I suppose 
it should be easy to migrate from IE on Windows to Firefox on Linux.
(In reply to comment #17)
> re comments #15 & #16.
> 
> Adding charset=iso-8859-1 for example to bookmark.htm doesn't help, Firefox 
> ignores it and imports it in any case as UTF-8.

You can file it as a separate 'bug'

 
> iconv probably works, but that requires special Linux knowledge, and I suppose 
> it should be easy to migrate from IE on Windows to Firefox on Linux.

How can firefox on Linux possibly know what character encoding you used on
Windows? Of course, you can file an enhancement request for prompting users to
select the character encoding of an IE-exported bookmark file? 

Neither of these two is this bug !

If you don't like iconv, you can just import IE favorites from firefox on
Windows and then move them to Linux. 
Status: NEW → ASSIGNED
(In reply to comment #18) 
 
The only reliable way to export from IE Favorites on Windows to FF bookmarks on 
Linux is to do it through FF on Windows. 
 
In that case, FF on Windows imports (as an optional step of the FF 
installation) IE Favorites from user's Favorites folder (which are actually 
file & folder names and files on a NTFS file system which is always Unicode). 
After the bookmarks have been imported into FF on Windows, they can be exported 
as FF-formatted bookmarks.htm file, which is encoded as UTF-8 (unlike IE and 
Konqueror, which don't specify encoding at all). That file can be imported 
without problem into FF on Linux. 
 
If we wanted to directly import from IE Favorites on Windows to FF on Linux, FF 
on Linux should read IE Favorites folder (and this is what Konqueror 4.3 on 
Linux actually offers). I understand that number of people that (a) directly 
swith from IE on Windows to FF on Linux and (b) use non-ASCII bookmark names is 
quite small so that this feature has not been implemented. 
 
Even when using bookmark.htm file and iconv to convert from non-Unicode 
bookmark.htm to UTF-8 we could be losing information, as the loss happens when 
IE exports from Favorites folder (UTF-8) to bookmark.htm. 
 
As you stated, any of this is only loosely related to this bug (only the part 
in which IE Favorites from Favorites folder are imported into FF on Windows). 
In NTFS, file names (Favorite names) are always Unicode (and I actually don't 
understand the title of this bug, as "the system default codepage", whatever it 
means on Windows, is not relevant. It might be that IE is not able to DISPLAY a 
Russian or Japanese Favorite on an English Windows, but that is only limitation 
of the FONT used to display Menus in that particular language version of 
Windows, not any defect in the Favorite name. 
(In reply to comment #19)
> (In reply to comment #18) 
>  
> The only reliable way to export from IE Favorites on Windows to FF bookmarks on 
> Linux is to do it through FF on Windows. 

I mentioned that in comment #19. So, what's the problem?
As for this bug, if you don't udnerstand, please, stop ranting. If you do wnat
to know what it's about, see bug 162361. 
(In reply to comment #20)
As per your suggestion, I looked at bug 162361 and now understand that full 
Unicode support in Firefox is a complicated issue. I am sorry for wasting your 
time, I won't be bothering again.
*** Bug 321638 has been marked as a duplicate of this bug. ***
This is now fixed on trunk thanks to the patch for bug 162361.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago14 years ago
Resolution: --- → FIXED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
fixed on branch as well.
Keywords: fixed1.8.1
*** Bug 235495 has been marked as a duplicate of this bug. ***
*** Bug 336467 has been marked as a duplicate of this bug. ***
*** Bug 355239 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.