Closed Bug 336815 Opened 17 years ago Closed 17 years ago

'Clear private Data' fails to clear 'saved form information'

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 333591

People

(Reporter: ht990332, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060504 Firefox/2.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060504 Firefox/2.0a1

Under 'clear private data' settings, if 'Browsing history' , 'saved form information' and 'Download histroy' are selected, then manually doing a Tools > 'Clear private data' , clears 'download history' , 'browsing history' but fails to clear 'saved form information'

Reproducible: Always

Steps to Reproduce:
Please follow the following steps:
1. Under 'clear private data' settings, choose ( tick to enable ) 'Browsing history', 'Download histroy' and 'Saved form information'
2. visit images.google.com and do a search for 'firefox' ( must be done from within images.google.com page).
3. Click Tools > 'Clear private data'.

Actual Results:  
'Browsing history', 'Download histroy' ARE cleared but 'Saved form information' is NOT cleared.

Expected Results:  
'Saved form information' should be cleared as well since in the settings it is ticked.

formhistory.sqlite file has something to do with this?
This used to work in 1.5.0.x
when I go back to images.google.com after clearing private data, I still see 'firefox' in formhistroy
I think I got it:
1. formhistory.dat  gets cleared but formhistory.sqlite does not.
2. This is my own build from cvs.

*** This bug has been marked as a duplicate of 333591 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.