[Feed Reader] Subscription Options: can't use/select "Use a Web Site" [windows]

RESOLVED FIXED in Firefox 2 alpha2

Status

()

RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: bugmozz, Assigned: bugs)

Tracking

({fixed1.8.1})

unspecified
Firefox 2 alpha2
x86
Windows XP
fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060506 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060506 Minefield/3.0a1 ID:2006050604 [cairo]

[error]
chrome://browser/content/feeds/options.js
line 88 : 0505 Minefield and 0506 Bon Echo 
line 80 : 0506 Minefield

[screen shot]
Minefield (0505 nightly and 0506 Nightly)
http://img128.imageshack.us/img128/7584/05059cw.jpg
http://img128.imageshack.us/img128/6223/05062jv.jpg

BonEcho (0506 Hourly)
http://img128.imageshack.us/img128/4930/bon6ki.jpg

Reproducible: Always

Comment 1

13 years ago
Confirming.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060507 BonEcho/2.0a1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [Feed Reader] can not use/select "Use a Web Site". → [Feed Reader] Subscription Options: can't use/select "Use a Web Site"

Comment 2

13 years ago
I still see this after the latest round of fixes.

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWindowsRegKey.open]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/feeds/options.js :: SO_init :: line 88"  data: no]

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a2) Gecko/20060509 BonEcho/2.0a2
Flags: blocking-firefox2?
Target Milestone: --- → Firefox 2 alpha2

Updated

13 years ago
Summary: [Feed Reader] Subscription Options: can't use/select "Use a Web Site" → [Feed Reader] Subscription Options: can't use/select "Use a Web Site" [windows]
Created attachment 221487 [details] [diff] [review]
patch

Have not tested this yet, waiting for my Windows XP VM install to complete since the systems they give us here don't have fast user switching enabled so I can test a restricted access or clean install (no feed reader).
Assignee: nobody → bugs
Status: NEW → ASSIGNED
Attachment #221487 - Attachment description: patch (untested) → patch
Attachment #221487 - Flags: review?
Attachment #221487 - Flags: review? → review+
tested on several machines and verfied to work. 

Comment 5

13 years ago
can't use/select "Use a Web Site" with :

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a2) Gecko/20060510 BonEcho/2.0a2 ID:2006051005


screenshot :

http://img112.imageshack.us/my.php?image=feedreader8pj.png
Attachment #221487 - Flags: approval-branch-1.8.1+
Checked in on the 1.8 branch.
mozilla/browser/components/feeds/content/options.js 	1.1.2.4
Keywords: fixed1.8.1
(Reporter)

Comment 7

13 years ago
confirmed on Bon Echo.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a2) Gecko/20060510 BonEcho/2.0a2 ID:2006051020
(Reporter)

Comment 8

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060510 Minefield/3.0a1 ID:2006051018 [cairo]

confirmed.

Thank you.
Landed by Ben on 5/10, marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Flags: blocking-firefox2?
*** Bug 337182 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.