Closed Bug 337192 Opened 17 years ago Closed 16 years ago

Dismissal of find bar differs for ctrl-f and / or ' invocations

Categories

(Toolkit :: Find Toolbar, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: pkasting, Assigned: pkasting)

References

Details

Attachments

(1 file)

When starting the find bar with / or ', clicking in the document or hitting TAB dismiss the find bar.  This does not happen when the find bar is started with ctrl-f.  Not only does this feel bizarrely inconsistent, but since either of these actions removes focus from the find bar, you can't even hit escape to close the bar if you meant to.  I think ctrl-f should behave like '/' in this case.

Patch coming up shortly.
Hmm.  A lot of other dismissal cases differ too, now that I read the code.  We don't hook up the dismissal timer in ctrl-f mode.  I suspect the original reason for this was to make ctrl-f search work similarly to the old modal find box, which didn't go away until you closed it.  I wonder if this is the best thing.  I'm inclined to move ctrl-f more toward / in terms of these dismissals as well, but I'd like to get a better feeling on how users would perceive this.

I also notice that checking the "match case" box means that escape no longer dismisses the bar.  Grr.
Here's a patch which provides what I'm suggesting.  I'm not going to ask for review until I have some kind of consensus that this is a good idea (thread posted on dev.apps.firefox about this).

This patch does several things:
(1) Hooks up the escape key on the Match Case button to dismiss the find bar.  This seems like a clear win to me.
(2) Causes mouseup on a page to dismiss the find bar even in ctrl-f mode.  This also seems like a clear win.
(3) Causes tab to act for ctrl-f like it already does for / and '.  Not as sure this is important or useful, but also doesn't seem harmful (since it only does something after a successful search, so it looks kind of like focus is already on the page).
(4) Sets up a timeout for ctrl-f mode like already exists for / and '.  This is arguable.  Maybe a longer timeout would be better.  Maybe we don't want a timeout here.

Comments welcome, especially if you play around with this patch and find it noticeably better or worse in some ways, or if I've overlooked something that should be addressed here.
Feel free to tell me to take this to another bug but:

When the find bar dismisses, it moves the scrollbar's down arrow. So if I Find some text, then click the arrow to go down, after five seconds the arrow moves out from under my mouse and I'm suddenly paging down instead of moving down line by line. Extremely irritating, but I'm not immediately sure how to solve it.

Gerv
There is indeed a different bug for that.  You're looking for bug 261937.  Note that fixing bug 171237 would hopefully result in less need for scrolling, which would make this bug less irritating.
Depends on: 337654
Is it possible to disable the invocation of the find bar using ['] or [/]? I was attempting to type a hyperlink in an email using gmail and it wouldn't allow me to since it would always bring up the find bar. Same in the instance of trying to type a contraction containing the symbol [']. Any suggestions for disabling this?
Please don't spam this bug with random questions; this is not tech support.

You're looking for bug 320465 or one of its blockers.

If you have a 100% reproducible testcase for that bug, I'm sure those folks would like to hear it.
(In reply to comment #6)
> Please don't spam this bug with random questions; this is not tech support.
> 
> You're looking for bug 320465 or one of its blockers.
> 
> If you have a 100% reproducible testcase for that bug, I'm sure those folks
> would like to hear it.
> 

I submitted a bug, I don't need your snotty overtones. The suggested one you gave has nothing on a resolution.
I'm not finding any bugs with you as the reporter, so I'm not sure which bug you're referring to.

As for "this is not tech support" being considered a "snotty overtone", please make sure you're familiar with https://bugzilla.mozilla.org/page.cgi?id=etiquette.html .  This is not a bug about disabling find bar invocation with / or ', so comments about that issue are more appropriate elsewhere.  And bugzilla is never an appropriate place to ask "how do I...?".  I'm not sure how finding an appropriate bug for your issue is "snotty", but perhaps the reason you didn't find a resolution there is because there isn't a resolution; it's an open bug.

If you wish to disable FAYT, consider filing a request for enhancement describing what you'd like to see.
OK, now that the two modes are visually distinct, I'm closing this as INVALID.  I'll take the escape-should-work-on-match-case stuff to a different bug.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → INVALID
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.